1

I installed usbip:

rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org
rpm -ivh http://www.elrepo.org/elrepo-release-7.0-3.el7.elrepo.noarch.rpm
yum install usbip-utils

Then I tried to load drivers:

modprobe usbip_core
modprobe usbip_host
modprobe: FATAL: Module usbip_host not found.

This sound strange. The module seems to do not exist. I tried to use usbip anyway:

usbipd -D

Worked.

usbip list -l - busid 3-1 (04e6:5116) SCM Microsystems, Inc. : SCR331-LC1 / SCR3310 SmartCard Reader (04e6:5116)

  • busid 3-14.1 (0557:2419) ATEN International Co., Ltd : unknown product (0557:2419)

Worked.

usbip --debug bind --busid=3-1
usbip: debug: usbip.c:141:[run_command] running command: `bind'
usbip: debug: sysfs_utils.c:17:[write_sysfs_attribute] error opening attribute /sys/bus/usb/drivers/usbip-host/match_busid
usbip: debug: utils.c:47:[modify_match_busid] failed to write match_busid: No such file or directory
usbip: error: unable to bind device on 3-1

doen't work. looking around it seems that usbip_host is missing. But I cannot load it because seems to be not shipped with usbip package.

I'm stuck

1 Answer 1

1

I just realised that the issue was in this answer:

USBIP on CentOS 7

Which there was a typo in the installation of kmod_usbip:

yum install ksmod-usbip
yum install usbip-utils

the first line is wrong. The module is just kmod not ksmod. The right command is:

yum install kmod-usbip

I'm gonna to fix original question

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.