0

How does one control automount ownership, i.e. the mount 'seat' ownership?

In Nemo's left pane, under Devices, manually clicking on a plugged-in, but not yet mounted, USB memory device, cause it to mount.

But some devices mount with root ownership (like my 2nd hard drive), and some with user ownership (like my USB sticks). In other words, my USB hard drive mounts in a folder owned by root, but my USB stick mounts in a folder owner by a normal user. I want the hard drive to mount as a normal user.

I can see that udisk2 is being used.

How do I set drive ownership, or override whatever the defaults are?

BTW, one issue this seems to create is that in Nemo when I delete a file or folder, it can't put it in the trash, (presumably because it doesn't have permission to). It only offers the option to delete permanently, or cancel.


Here's what I've tried:

I can manually mount with udisksctl mount --block-device=/dev/sdd1. I don't see an option in gnome-disks-utility, nor in the settings available for udisks. I tried to mess w/ polkit, but so far not sure if anything I do changes anything. Also I've tried messing with /etc/fstab but can't seem to add uid or user-id options.

Here is the rules file I tried to setup /etc/udev/rules.d/99-my.rules

SUBSYSTEM=="kernel", OWNER="user1", GROUP="group1", MODE="0777" SUBSYSTEM=="block", OWNER="user1", GROUP="group1", MODE="0777"

(I know that these are too permissive, but I was figuring if I could get it to work, that later I would tighten them up.)

3) BTW, I don't have any files in /etc/udisks2/, and have not yet tried messing with this.


My platform:

OS: GNU/Linux Debian 9.6 (x86-64); 
Cinnamon desktop: 3.2.7; 
Linux Kernel: 4.9.0-8-amd64; 
0

While the drive is mounted (via Nemo) change the ownership of the seat (i.e. the subdir it's mounted to). That's it.

Test it: Unmount (via Nemo), verify that the auto-created seat gets removed. Then have Nemo remount. Magicaly the ownership of the seat is restored just as it was before it was unmounted and removed.

Now when you delete files in this mounted partition, they properly get put in trash, and later emptying the trash for this partition also works.


BTW, Disks, i.e. gnome-disk-utility, is pretty neat, and does more than I had expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.