1

i tried installing ARCH and everything seems to work pretty fine. I followed this installation for the most part (https://gitlab.com/jsherman82/notes/blob/master/arch.md)

But i seem to have a problem with the installtion of the bootloader and its configuration.

My System has three partitions:

nvme0n1p1 with 400MiB of type EFI System mounted at /boot/EFI
nvme0n1p2 with 400MiB of type ext2 mounted at /boot
nvme0n1p3 with the rest of the disk (~240GiB) of type lvm

nvme0n1p3 is encrypted via cryptsetup and split into two lvm-partitions:

main-root with 30GiB mounted at /
main-home with the rest mounted at /home

So far so good.

I edited this line of /etc/default/grub to read like this:

GRUB_CMDLINE_LINUX_DEFAULT="cryptdevice=/dev/nvme0n1p3:main quiet"

But when I did Step 38) # grub-mkconfig -o /boot/grub/grub.cfg nothing happens. There is no output and the terminal is stuck with a blinking cursor. I have to manually stop the program via ^C. I tried the same command without writing to a file - just a blinking coursor.

/boot/grub does not have a grub.cfg-file in it (obviously).

I need to solve this problem and generate a grub.cfg-File.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.