0

This question already has an answer here:

I'm trying to install certbot on my Debian 9 server on Google compute engine VM.

Here's what I have done so far: To add backports repository, I have edit the sources.list as:

sudo nano /etc/apt/sources.list

Then add this line at the very bottom of the file:

deb http://ftp.debian.org/debian stretch-backports main

After that when I run this command:

sudo apt update

it return this error:

Reading package lists... Done

W: GPG error: http://ftp.debian.org/debian stretch-backports

InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010

E: The repository 'http://ftp.debian.org/debian stretch-backports InRelease' is not signed.

N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

marked as duplicate by GAD3R, elbarna, Christopher, Thomas, Mr Shunz Feb 4 at 10:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

This should answer your question directly. Should even be able to copy and paste the commands.

https://rolfje.wordpress.com/2017/06/09/installing-gpg-keys-for-debian-backports/

Not the answer you're looking for? Browse other questions tagged or ask your own question.