1

Trying to YUM install gcc gcc-g++ make and it fails with:

Package: glibc-2.17-260.el7.i686 (RHEL_SEC_7)
       Requires: glibc-common = 2.17-260.el7
       Installed: glibc-common-2.17-260.el7_6.3.x86_64 (@anaconda/7.6)
           glibc-common = 2.17-260.el7_6.3
       Available: glibc-common-2.17-55.el7.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-55.el7
       Available: glibc-common-2.17-55.el7_0.1.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-55.el7_0.1
       Available: glibc-common-2.17-55.el7_0.3.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-55.el7_0.3
       Available: glibc-common-2.17-55.el7_0.5.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-55.el7_0.5
       Available: glibc-common-2.17-78.el7.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-78.el7
       Available: glibc-common-2.17-105.el7.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-105.el7
       Available: glibc-common-2.17-106.el7_2.1.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-106.el7_2.1
       Available: glibc-common-2.17-106.el7_2.4.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-106.el7_2.4
       Available: glibc-common-2.17-106.el7_2.6.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-106.el7_2.6
       Available: glibc-common-2.17-106.el7_2.8.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-106.el7_2.8
       Available: glibc-common-2.17-157.el7.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-157.el7
       Available: glibc-common-2.17-157.el7_3.1.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-157.el7_3.1
       Available: glibc-common-2.17-157.el7_3.2.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-157.el7_3.2
       Available: glibc-common-2.17-157.el7_3.4.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-157.el7_3.4
       Available: glibc-common-2.17-157.el7_3.5.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-157.el7_3.5
       Available: glibc-common-2.17-196.el7.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-196.el7
       Available: glibc-common-2.17-196.el7_4.2.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-196.el7_4.2
       Available: glibc-common-2.17-222.el7.x86_64 (RHEL_7.6)
           glibc-common = 2.17-222.el7
       Available: glibc-common-2.17-260.el7.x86_64 (RHEL_SEC_7)
           glibc-common = 2.17-260.el7

However, output of yum list --showduplicates glibc shows:

Installed Packages
glibc.x86_64                   2.17-260.el7_6.3                   @anaconda/7.6 

and yum list --showduplicates glibc-commonshows:

Installed Packages
glibc-common.x86_64               2.17-260.el7_6.3                @anaconda/7.6 

A snippet of the output of yum -v -y install gcc gcc-c++ make shows:

Package glibc.i686 0:2.17-260.el7 will be installed

Why does yum try to mix architectures? How can I force yum to install only x86_64 dependencies?

2

The gcc package is somewhat special, because the compiler in it can produce both 32-bit and 64-bit libraries. For that to work, it needs some basic i686 system libraries (libgcc and glibc). There's not much you can do about it, apart from recompiling the compiler to disable 32-bit support.

You'd better figure out why glibc.i686 fails to install. Looks like a release mismatch, possibly due to an incompatible mix of repos (you have the el7_6.3 release of glibc-common installed, but the glibc.i686 package wants el7).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.