0

I have an Odroid XU4 arm Linux PC(Ubuntu mate 18.04) with glxgears and I have a Ubuntu 18.10 pc. I want to run glxgears on my odroid arm pc, but have the OpenGL commands send to mu Ubuntu 18.10 pc(so it's hardware accelerated).

I enabled tcp on my x11 server on the PC, and enabled the SSH server on the ODROID. Then I connect to the odroid with ssh -X odroid@odroid.local. When it's connected, I can run firefox and have it display on my pc as it should. But when I run glxgears, it errors with Error: couldn't get an RGB, Double-buffered visual It does this with any other OpenGL program I try. So presumable OpenGL passthrough isn't working. But I can't figure out the problem.

I also tried export LIBGL_ALWAYS_INDIRECT=1 before running glxgears, but it didn't work. Both the ODROID and my PC can run glxgears fine on their own, it's the tunneling of OpenGL that fails.

1

It seems that you may be experiencing a driver issue where the instructions for 3d rendering are not able to translate to the native environment in which you wish to view glxgears or 3d renderings.

There is reference to a similar issue here: https://github.com/Bumblebee-Project/Bumblebee/issues/356 , this is a local issue no ssh X11Forwarding, however in principle it is the same.

I believe this to be the case, because your hardware is not the same on the viewing end as you stated "so it is hardware accelerated". I would go further to say you may even have nVidia drivers loaded on said system or other proprietary drivers.

I believe this issue is insurmountable with the chosen method of viewing 3d rendered images with given hardware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.