1

I updated my system using yaourt -Syua and there was an update for the Linux kernel. I tried rebooting and got:

loading linux linux...
loading ramdisk...
Then crash and redirection to the emergency shell, like described in the link below: https://bbs.archlinux.org/viewtopic.php?id=237303

I use UEFI and grub.

I can't type anything in the emergency shell because my keyboard doesn't work.

I tried using a bootable archlinux on USB drive but failed with

SQUASHFS: xz decompression failed, data probably corrupt

Details about my hard drive : I have a dual boot Linux/Windows with some system partitions.

Is there a way to fix my system without losing data?

  • Try use fallback initramfs. If that doesn't work, try Remake a live USB(see ArchWiki), chroot into your system. use pacman to update your kernel again. I guess You have interrupted your system update process. – 炸鱼薯条德里克 Feb 1 at 12:49
  • Well my bootable USB stopped working. I'm burning the 2019/01/01 iso from my Windows. – Jean-Marc Zimmer Feb 1 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.