0

So I just installed Linux mint 18 yes 18 not 19 and ran sudo apt-get update also ran sudo apt-get update Firefox and I run these commands I got errwith the repository’s then running the second command I get Firefox is up to date then I run sudo apt-get install libness and am told there is nothing to update but then I run sudo apt-get install libness3-dev and then I get the following additional packages will be installed: libnsprv4-dev the following NEW PCKAGES will be installed libnspr4-dev libness3-dev That’s all good but then I re run sudo apt-get update and all of a sudden I don’t get err when updating then upgrading, but befor I ran sudo apt-get install libness3-devi couldn’t access the repository’s why running sudo apt-get install libness3-devcompletely update my repository list? I don’t understand why adding -dev I managed to get like over 800 upgrades

0

(While reading the question, I felt a little short of breath in sympathy.)

Don't panic. Welcome to Unix&Linux.SE, by the way.

Things that happen one after another don't always have to be causally related to each other.

By association with libnspr4-dev, I assume you mean libnss3-dev. But the act installing these packages is unlikely to have updated your repository list.

You said you first got a repository error and then didn't, and got a large number of updates instead.

It sounds like there was something wrong with the repository originally, possibly causing you to miss some updates. Or perhaps the repository was in the process of downloading a big set of new updates from the main Mint repository, and its index files were temporarily out of sync with the true state of the repository. That could cause a repository error when trying to update/upgrade, but would still allow you to install those packages that were already present in the repository.

Then, when you tried a second time, the repository server had completed the download operation (or whatever problem there was had been fixed) and was again fully ready to serve you. And now it had a big set of new updates ready for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.