2

host: Ubuntu 64-bit

local: macOS 10.13 64-bit

I'm attempting to run a program on a remote Linux machine through ssh, and I want the GUI to appear on my local macOS laptop.

When I execute ssh -v -X user@host or ssh -v -Y user@host, I receive two messages that may be worth noting:

With -X flag:

debug1: No xauth program.
Warning: Untrusted X11 forwarding setup failed: xauth key data not generated

With -Y flag:

debug1: No xauth program.
Warning: No xauth data; using fake authentication data for X11 forwarding

When I log onto the host, and execute which xauth I get the output: /usr/bin/xauth, which is confusing me because ssh is stating that there is no xauth program.

Additionally, when I do end up running the program thru ssh on my mac (just the command line version, no graphics), I get these errors:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  23
  Current serial number in output stream:  26

How can I fix this so that I can enable graphics to run on my local mac from the host Linux computer?

Edit: When I type which xquartz on my local mac: /opt/X11/bin/xquartz

  • 1
    Do you have an X server running on the macOS machine, for example XQuartz? – Kusalananda Jan 31 at 16:43
  • @Kusalananda Yes I have XQuartz on my mac, it's in /opt/X11/bin/xquartz. – NaN Jan 31 at 16:46
  • 1
    Is out of question including that in the question? – Rui F Ribeiro Jan 31 at 16:51
  • Maybe ssh tries to use a local xauth to get the authorization information. – Bodo Jan 31 at 17:12
1

1) The problem is that ssh looks for xauth in wrong path - on Ubuntu it is /usr/bin/xauth but on MacOS it is /opt/X11/bin. This can be solved by edit your local ssh config file. ( ~/.ssh/config, add XAuthLocation /opt/X11/bin/xauth)

2) It seems a problem with xquartz. I know one "solution" is to downgrade XQuartz to version 2.7.8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.