77

I have a Unix-like OS installed without a windowing environment; i.e., just a text-mode console and no GUI.

Is it possible to change the font used by the console?

To be clear, I am not talking about the terminal emulator that comes with a desktop environment like KDE or GNOME.

2

7 Answers 7

74

If you use the Linux console, the best way I found is:

in

/etc/default/console-setup

put, for example

CHARMAP="UTF-8"
CODESET="Lat7"
FONTFACE="Terminus"
FONTSIZE="28x14"

Another way is to use setfont from the kbd package:

setfont /usr/share/consolefonts/Lat7-Terminus28x14.psf

This works for my Debian; it may be different for you.

In Debian, you can also run dpkg-reconfigure -plow console-setup to be prompted for the various console settings and pick them from menus.

Edit - I put together a small page how to setup the font colors. The section that is relevant for this post has the header "the Linux VTs" (= ttys, or "console").

6
  • 13
    Font sizes listed by dpkg-configure console-setup are: 6x12, 8x14, 8x16, 10x20, 11x22, 12x24, 14x28, and 16x32. Commented Apr 8, 2015 at 5:17
  • 1
    I had to reboot for this to take effect
    – mt025
    Commented Apr 5, 2017 at 0:11
  • 1
    I used dpkg-reconfigure console-setup solution, and after i made my selections of font options, it modified /etc/default/console-setup and ran update-initramfs (i suppose with -u option). However, your answer does not mention running update-initramfs. Is it necessary?
    – Alexey
    Commented Jul 28, 2018 at 13:33
  • 1
    @mt025 you may use the command setupcon to apply the changes. It is part of the console-setup package. Commented Mar 3, 2020 at 6:22
  • 1
    On some distros (at least on Arch), the fonts will be in /usr/share/kbd/consolefonts. I will add a separate answer to highlight the setfont solution. Commented Mar 5, 2020 at 12:23
16

/etc/default/console-setup et al. have been superseded on systemd operating systems, although you will find that some operating systems such as Debian try to maintain the older configuration system.

The way to do this on a systemd operating system is to edit the font settings in the /etc/vconsole.conf file. These settings are applied by the systemd-vconsole-setup service, which is essentially a glorified way of running setfont and loadkeys before the login services are brought up.

So you would have FONT=Uni2-Terminus28x14 in that file, for example.

Note that the service program allows kernel command-line options such as vconsole.font to override /etc/vconsole.conf contents. If you are mucking around with GRUB kernel command-line options, bear this in mind.

Further reading

2
  • The problem with this approach is that it is systemd-specific and changes the default for all users.
    – fpmurphy
    Commented Oct 18, 2017 at 10:42
  • 2
    FONT=Uni2-Terminus28x14 does not seems to work because there is no such font in my Arch-based system. Actually I don't care about the font face itself, but all I want is making the text bigger, because it is too small to read. Isn't there any way just to double or triple the console text size, without changing the font face? Commented Feb 28, 2023 at 5:05
11

Using Ubuntu 16.04 (probably works in all supported versions), I edited ~/.bashrc and just before terminal splash at end of file, inserted the setfont command:

# Set font when running in console
/bin/setfont /usr/share/consolefonts/Lat2-Terminus32x16.psf.gz    

# Splash Calendar and time
now

# ASCII Linux distribution display
screenfetch

Now when selected Ctrl+Alt+F1 through Ctrl+Alt+F6 and get nice big fonts.

This is the largest font available and you can see a complete list with ls command:

$ ls /usr/share/consolefonts
Arabic-Fixed15.psf.gz             Lat15-Terminus20x10.psf.gz
Arabic-Fixed16.psf.gz             Lat15-Terminus22x11.psf.gz
Arabic-VGA14.psf.gz               Lat15-Terminus24x12.psf.gz
    (... SNIP ...)
Lat15-Terminus14.psf.gz           Vietnamese-Fixed16.psf.gz
Lat15-Terminus16.psf.gz           Vietnamese-Fixed18.psf.gz

Sample screen

This is a facsimile, not a true screen capture from console where screen is wider by 20% and background is black:

Sample console fonts

Prior to changes I couldn't read the screen on HDPI monitor.

3
  • 1
    That's nothing to do with the question. You're running a terminal in a gui.
    – RichieHH
    Commented Dec 8, 2020 at 23:22
  • 3
    @RichieHH The ~/.bashrc is processed when you open a terminal too. I just can't do a screen shot of a terminal session because there is no GUI running. Commented Dec 9, 2020 at 12:49
  • A user having some trouble with the instructions: askubuntu.com/questions/1409347/…
    – muru
    Commented May 19, 2022 at 1:18
9

If you want to use nearly any X-compatible font you should have a look at David Herrman's work on kmscon. The name slightly belies the project, actually, as Kernel Mode Setting is not a requirement for it to work - it also works with with frame-buffer devices - for instance if you are using proprietary AMD or nvidia display drivers. With kmscon you get multi-seat session management, xterm like keyboard and UTF-8 font handling and session control. Changing the font can be done via the /etc/kmscon/kmscon.conf or via a command-line option.

2
  • Given the age of this answer this makes sense, but for anyone reading this answer nowadays, there appears to have been no update to kmscon since 2014. I can imagine there are lot of security and compability issues with such an unmaintained tool Commented Jul 5, 2022 at 4:14
  • Project is not dead, it's just that development happens on different branches nowadays: github.com/Aetf/kmscon is the main one, and github.com/MacSlow/kmscon has a lot of cool, experimental new features. Commented Jun 24, 2023 at 3:29
7

setfont worked for me. Choose a font; usually they are listed in one of these:

  • /usr/share/consolefonts
  • /usr/share/kbd/consolefonts

For example, to use the font /usr/share/kbd/consolefonts/ter-v32n.psf.gz, you can enter

setfont ter-v32n
6

A dead-simple, if inflexible, solution is to run setfont -d, which doubles the size of the current font. Running it twice won't quadruple the size, though (or at least not on my system).

3
  • At first i thought it did not work, because I ran it with sudo. I removed sudo and then it worked. But this seems to be applied to only the current session. If I log out and re-log in, the font goes back to its original size. How to make it persistent? Commented Feb 28, 2023 at 5:13
  • I imagine putting the command in some file that loads when you start the shell -- ~/.inputrc or ~/.profile, for instance -- would have that effect. Commented Mar 1, 2023 at 16:31
  • /usr/lib/kbd/consolefonts/ on Fedora Commented Jan 7 at 22:51
-2

In Linux Mint 18.1 terminal:

  1. Right click anywhere in the black space.
  2. Choose "profiles", "profile preferences".
  3. Put a tic in "custom font" box.
  4. Click on the big text sample box next to it.
  5. Choose whatever font size and type you want.

The changes will appear immediately.

2
  • 2
    I think the question is about Linux console (tty1 -- tty8).
    – Alexey
    Commented Jul 11, 2017 at 7:32
  • You saw the words without desktop @Never Too Old To Learn?
    – alamin
    Commented May 3, 2018 at 16:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .