0

I need to install NordVPN into Linux Tails. Followed the instructions to perform in a Terminal window for the normal NordVPN https://nordvpn.com/download/linux/ :

sudo apt-get install /home/amnesia/Desktop/nordvpn-release_1.0.0_all.deb

After a few seconds, confirmed I wished to proceed, then got:

*Get:1 /home/amnesia/Desktop/nordvpn-release_1.0.0_all.deb nordvpn-release all 1.0.0 [5,358 B]  
[INFO] Saving package changes  
Traceback (most recent call last):  
  File "/usr/lib/python3/dist-packages/apt/cache.py", line 194, in __getitem__
    return self._weakref[key]  
  File "/usr/lib/python3.5/weakref.py", line 137, in __getitem__  
    o = self.data[key]()  
KeyError: 'nordvpn-release'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apt/cache.py", line 198, in __getitem__  
    rawpkg = self._cache[key]
KeyError: 'nordvpn-release'


During handling of the above exception, another exception occurred:  

Traceback (most recent call last):  
  File "/usr/local/sbin/tails-additional-software", line 671, in <module>  
    apt_hook_pre()  
  File "/usr/local/sbin/tails-additional-software", line 459, in apt_hook_pre  
    if not apt_cache[package_name].is_installed:  
  File "/usr/lib/python3/dist-packages/apt/cache.py", line 200, in __getitem__  
    raise KeyError('The cache has no package named %r' % key)  
KeyError: "The cache has no package named 'nordvpn-release'"  
N: Download is performed unsandboxed as root as file  
 '/home/amnesia/Desktop/nordvpn-release_1.0.0_all.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)  
E: Sub-process /usr/local/sbin/tails-additional-software apt-pre returned an error code (1)  
E: Failure running script /usr/local/sbin/tails-additional-software apt-pre*  

How do I overcome this failure?

  • As you're new here: If one of the answers below solved your problem, don't forget to click the grey ☑ at the left of its text, which means Yes, this answer is the most useful of all! unix.stackexchange.com/help/accepted-answer – K7AAY Feb 4 at 18:35
2

Since Linux Tails forces all connections through Tor, it won't work. However, this blog post says you can use a VPN with Tor Browser (less safe, they say) or Whonix (more safe, they say).

Therefore, I suggest you review the pros and cons of Tor Browser on another Linux vs Whonix, and decide which suits your needs better.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.