I am on Ubuntu 18.04 (Kubuntu), running through Konsole.

I have a node process I can see in htop if I F4 and search for node. I highlight it and use F9 to send it a signal (tried SIGINT, SIGQUIT, SIGTERM, SIGKILL), but nothing causes it to exit.

This is not specific to node, as I can't SIGKILL other things (for example the Kate text editor).

If I exit htop and simply type kill -SIGINT 6015 (PID taken from htop), the process exits properly.

Why is this not working?

I am guessing it has something to do with how the desktop version works, because on servers I have never had the issue of htop being unable to signal processes.

Another thing that goes contrary to my expectations is if I run sudo htop I can only see about 4 processes under my user (3 related to kde and one (sd-pam)) whereas running it as myself shows me 100+ (including node and all the other apps I have going). I would expect that running as root I would see all processes for all users.


I have good news, and bad news.

Kill works for htop installed with sudo apt install htop.

Kill doesn't works for htop installed with sudo snap install htop.

I believe snap's sandbox is blocking the signal. Also, the htop from snap list fewer processes than the htop from apt.

  • 1
    Thank you, Marcos! I was not aware of snap sandboxing applications installed through it. Removing htop via snap and installing via apt solved my issue. I am now able to send signals and see all the processes I expected to see. – Alex Feb 4 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.