1

I am trying to clone Wayland repository from git (for a project) but git clone command is throwing me an error.

I installed curl (from here). After cloning make && make install. Earlier I had a different version which was working fine with git.

Then I again tried cloning Wayland repository and this error popped.

fatal: unable to access 'https://github.com/nobled/wayland.git/': Protocol "https" not supported or disabled in libcurl

so tried building curl as ./configure --with-ssl=/usr/local/ssl but I am not able to make any visible changes in curl's behaviour

/usr/local/ssl is a bad --with-ssl prefix!

I also tried this with /etc/ssl/ but failed

/etc/ssl is a bad --with-ssl prefix!

Any suggestion what may have caused this?

  • Is reinstalling the former curl out of question? You appear to already known that it is the curl you compiled that is causing this, why the question at the end? – Rui F Ribeiro Jan 30 at 12:22
  • @RuiFRibeiro Inspite of the fact that this has something to do with the curl (newer version) that I installed. But even when I am doing ./configure --with-ssl=/path/to/some/ssl it is not working. That leaves me wondering if I am giving the right SSL path. Which path should I use? What should be the content of the directory(of which the path is). – RC0993 Jan 30 at 12:28
  • I can confirm the error with openssl v1.1.1a, at least I wasn't able to build curl with it. Try openssl 1.0.2q. For more details about the different versions check openssl.org/source – Michael D. Jan 30 at 18:48
0

The switch

--with-ssl={gnutls,openssl}

needs the location of the the header files (*.h) usually in /usr/include/openssl it's a good idea to run configure with --includedir=/usr/include/ telling configure where to look for includes.

If /usr/include/openssl exists on your system and is having *.h files - it should be the right place.

You need to install the

openssl-devel (cent / redhat with yum) or libssl-dev (debian, ubuntu with apt) package otherwise. (Or clone the files from github.com 1.1.1 stable branch).

--with-ssl=/usr/include/openssl

EDIT:

ls /usr/include/openssl
aes.h        buffer.h     cterr.h   engineerr.h  md5.h          pem.h        rsa.h        symhacks.h
asn1err.h    camellia.h   ct.h      engine.h     mdc2.h         pkcs12err.h  safestack.h  tls1.h
asn1.h       cast.h       des.h     e_os2.h      modes.h        pkcs12.h     seed.h       tserr.h
asn1_mac.h   cmac.h       dherr.h   err.h        objectserr.h   pkcs7err.h   sha.h        ts.h
asn1t.h      cmserr.h     dh.h      evperr.h     objects.h      pkcs7.h      srp.h        txt_db.h
asyncerr.h   cms.h        dsaerr.h  evp.h        obj_mac.h      rand_drbg.h  srtp.h       uierr.h
async.h      comperr.h    dsa.h     hmac.h       ocsperr.h      randerr.h    ssl2.h       ui.h
bioerr.h     comp.h       dtls1.h   idea.h       ocsp.h         rand.h       ssl3.h       whrlpool.h
bio.h        conf_api.h   ebcdic.h  kdferr.h     opensslconf.h  rc2.h        sslerr.h     x509err.h
blowfish.h   conferr.h    ecdh.h    kdf.h        opensslv.h     rc4.h        ssl.h        x509.h
bnerr.h      conf.h       ecdsa.h   lhash.h      ossl_typ.h     rc5.h        stack.h      x509v3err.h
bn.h         cryptoerr.h  ecerr.h   md2.h        pem2.h         ripemd.h     storeerr.h   x509v3.h
buffererr.h  crypto.h     ec.h      md4.h        pemerr.h       rsaerr.h     store.h      x509_vfy.h

EDIT2:

Make sure it's openssl v1.0.2. Compiling curl doesn't seem to work with openssl v1.1.1a

  • Yea I tried this just now. giving the error as configure: error: /usr/local/include/openssl is a bad --with-ssl prefix!. I am not sure about the root cause. – RC0993 Jan 30 at 12:33
  • why /usr/local/include and not /usr/include/ ? – Michael D. Jan 30 at 12:42
  • that's my default for manual installations. Should that cause a problem here? – RC0993 Jan 30 at 13:05
  • If /usr/include/openssl exists on your system and is having *.h files - it should be the right place. – Michael D. Jan 30 at 13:08
  • Well I have the .h files in /usr/local/include/openssl Why should this not work? Is it necessary to put in /usr/include ? *(Can we go to chat? I don't know how to launch it) – RC0993 Jan 30 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.