0

I was trying to install an old optical drive into my system, which turned out to be having problems, so I pulled it out again, but upon rebooting back into Ubuntu 18.04, I'm unable to mount my 3-drive (16TB) linear lvm volume. I keep getting the message:

mount: /home/kp/bigdrive: mount(2) system call failed: Structure needs cleaning.

I ran sudo e2fsck /dev/bigVG/bigvol and it comes back clean (without errors) every time. Also, the volume mounts just fine using the Ubuntu 18.04 live CD. No problems whatsoever. I'm really baffled here. Is there some kind of cached file I need to clear or something?

  • The fsck /dev/bigVG/bigvol won't check the volume if it thinks it's already clean. (Typically it's considered clean if the last umount was successful.) You need the -f flag to force the check. – roaima Feb 1 at 7:32
1

As I just posted in the other thread, the kernel package linux-image-4.15.0-43-generic works for me, while linux-image-4.15.0-44-generic has the "Structure needs cleaning" bug described above.

  • Wish I had seen this sooner, but I needed to get the file server up and running. Anyway, now I know. Thanks for the info. – kegepet Jan 31 at 1:08
1

OK, I noticed another post in the SuperUser forum from yesterday and the problem described is identical to my own. As I mentioned in my initial post, the 18.04 live cd mounts the volume fine. Today, I tried the 18.10 live cd and that too mounted the volume without issue. I first reinstalled 18.04 from scratch (along with all available updates), but the problem persisted. Finally, I installed 18.10 and the volume mounts perfectly. So, I'm guessing something broke with some recent update for 18.04. Any info would still be appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.