1

My client is Windows 10 and my server is Ubuntu 16.04. I was able to connect, however suddenly was unable to. I have tried reinstalling my client on Windows 10, however it doesn't work.

On the server, my logs say connection established and do not show an error. On my client a message pops up saying 'The remote proxy closed the connection while negotiating. This may be due to wrong authentication credentials passed to the server' But, on my server it says connection established.

systemctl status x2goserver says

  • Successful su for x2go_user by root
  • + ??? root:x2go_user
  • pam_unix(su:session): session opened for user x2go_user by (uid=0)
  • Successful su for x2go_user by root
  • + ??? root:x2go_user
  • pam_unix(su:session): session opened for user x2go_user by (uid=0)

I am able to connect via SSH (PuTTy) and I'm using XFCE and same error even if I switch it. If I connect to the server with OpenVPN and try connecting, that doesn't work either.

X2GO client log text:

Connection timeout, abortingError: The remote NX proxy closed the connection.
Error: Failure negotiating the session in stage '7'.
Error: Wrong version or invalid session authentication cookie

Server session.log:

Info: Agent running with pid '32736'.
Session: Starting session at 'Mon Jan 28 23:16:50 2019'.
Info: Proxy running in client mode with pid '32736'.
Info: Using errors file '/tmp/.x2go-x2go_user/C-x2go_user-51-1548735407_stDXFCE_dp32/session.log'.
Info: Using stats file '/tmp/.x2go-x2go_user/C-x2go_user-51-1548735407_stDXFCE_dp32/C-x2go_user-51-1548735407_stDXFCE_dp32/stats'.
Loop: WARNING! Unrecognized session type 'unix-kde-depth_32'. Assuming agent session.
Warning: Unrecognized session type 'unix-kde-depth_32'. Assuming agent session.
Info: Waiting for connection from 'localhost' on socket 'tcp:*:42851'.
Loop: WARNING! Refusing connection from 'serverip' on port '42851'.
Warning: Refusing connection from 'serverip'.
Loop: PANIC! Connection with remote host 'localhost' could not be established.
Error: Connection with remote host 'localhost' could not be established.
Error: Aborting session with 'Unable to open display 'nx/nx,options=/tmp/.x2go-x2go_user/C-x2go_user-51-1548735407_stDXFCE_dp32/options:51''.
Session: Aborting session at 'Mon Jan 28 23:17:40 2019'.
Session: Session aborted at 'Mon Jan 28 23:17:40 2019'.

It seems to be refusing connection to itself?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.