1

I was trying to increase the screen resolution on my Ubuntu 16 Desktop (running on Virtual Box on Windows 10), and I went to System -> Software & Updates -> Additional Drivers tab, and selected "Using x86 virtualization solution - X11 guest utilities from virtualbox-guest-x11 (proprietary)".

Now when I try to access my virtual machine through the Virtual Box console, I get an error that says "the system is running in low graphics mode", and the desktop never loads.

When I SSH into the machine and run grep EE /var/log/Xorg.0.log, I get the following:

(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(EE) open /dev/dri/card0: No such file or directory
(EE) open /dev/dri/card0: No such file or directory
(EE) open /dev/dri/card0: No such file or directory
(EE) open /dev/dri/card0: No such file or directory
(EE) open /dev/fb0: No such file or directory
(EE) open /dev/fb0: No such file or directory
(EE) open /dev/fb0: No such file or directory
(EE) open /dev/fb0: No such file or directory
(EE) Screen 0 deleted because of no matching config section.
(EE) Screen 0 deleted because of no matching config section.
(EE) Screen 0 deleted because of no matching config section.
(EE) Screen 0 deleted because of no matching config section.
(EE) AIGLX: reverting to software rendering

One of the lines that I get after runninglpsci is

VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter

I have guest additions installed. When I do lsmod | grep vboxguest, I get the following

vboxguest           286720  2 vboxsf

How do I either revert to the working graphics adapter, or fix this new adapter that I switched to?

  • Was the RAM that high and 3d acceleration enabled during install? – Michael Prokopec Jan 29 at 22:16
  • No, it wasn't that high during install. I changed it afterwards, through Virtual Box (rather than setting them through the vagrantfile). – Ben Rubin Jan 29 at 22:17
  • I think that may be the cause of this, however I am still working on finding a solution with a virtualbox I just created to try to reproduce this issue. – Michael Prokopec Jan 29 at 22:20
2

Install the guest additions within the virtual OS using the guest additions CD that was included or download the latest and install it.

Also make sure you have enough ram allocated to the graphics and 3D acceleration is set to on.

Also since you are on Windows 10 try running VirtualBox as Administrator. If that does not help stop doing it, this can become a severe security risk!

You could also try reinstalling the guest additions now that the RAM is higher by running one of the following:

sudo apt-get install virtualbox-guest-utils virtualbox-guest-x11 virtualbox-guest-dkms

sudo apt-get --reinstall virtualbox-guest-utils virtualbox-guest-x11 virtualbox-guest-dkms
  • 2
    I have the guest additions installed. I updated my question to mention that. I have 128 MB of video memory assigned in Virtual Box, and I have the "enable 3D acceleration" box checked. – Ben Rubin Jan 29 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.