3

I just got a Oryx Pro, model Oryp4, from System76 and installed Void Linux on it. When I try to power it off or reboot I just get these messages and this dmesg.

I have tried adding acpi=off to /etc/default/grub on the line GRUB_CMDLINE_LINUX_DEFAULT . When I run

sudo poweroff

the machine it hangs on

reboot: System halted.

  • 1
    Upgrade the BIOS/firmware. – Rui F Ribeiro Jan 28 at 18:17
  • linux.die.net/man/8/shutdown; note the -h and -H and -P options. How are you shutting down? And if your Systemd based then the shutdown or init commands may not directly apply but they typically map to corresponding systemd service. – ron Jan 28 at 18:53
  • Void Linux: We use runit as the init system and service supervisor. runit is a simple and effective approach to initialize the system with reliable service supervision. See the usage page for a brief introduction. Not a fork, Void Linux is an independent distribution, developed entirely by volunteers. Being what it is, would not surprise me if it's a Void Linux problem/bug, – ron Jan 28 at 19:06
0

After submitting a ticket to System76 they told me to install the latest NVIDIA drivers and it goes through poweroff normall.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.