0

I have a VCSA that won't boot. It gets as far as:

A start job is running for dev-disk-by\x2dpar...dffa6b3c0a51f.device (no limit)

What I'm trying to do is track down that UUID so I can start troubleshooting. This what I've attempted so far:

  1. Tried emergency mode - can't get past the start job
  2. Mounted an Ubuntu Live ISO, mounted the / filesystem and checked fstab - No mention of 'dffa6b3c0a51f' or anything close
  3. Commented out the swap entries in /etc/fstab - same issue upon boot
  4. Checked /var/log/messages for any clues - last entry was 12/11/18
  5. Checked and force repaired all of the filesystem - including LVMs
  6. Copied the system.journal to the rescue system and attempted to read the entries - No entries, last entry was on 12/11/18
  7. Researched the error. Suggestions so far have been:

systemctl show -p RequiredBy -p WantedBy dev-disk-by...

systemctl list-units | grep dev-disk

The problem here is that I can't get past the start job message as it's set to infinite and I can't cancel it. I've tried adjusting the timeout in systemd.conf to 90s but it didn't take.

This is the fstab from the mounted partition:

enter image description here

This is what I'm seeing on boot:

enter image description here

So here I am. Has anyone encountered this before and if so, how did you fix it?

1

This is your device entry in crypttab having an error. Those generators are the only ones that tweak the device unit's timeout (if you didn't) and set it to infinity. This is because device units are exposing system resources, and systemd doesn't control their starting and stopping. However, it uses the start job as a way to wait for a device's appearance. This also means that device units cannot wait on another unit.

Now, for encrypted devices, they will never become active before the user enters the password (or unlocks the device through something equivalent), but the device unit cannot wait on the password prompt unit. This means that the device unit is set to wait infinitely long for the appearance of a device, which means the start job keeps running with no limits set on it. Dependents will be waiting on the running start job.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.