0

i want use openvpn on Linux Mint. When i tries the VPN connection (i am client) i writes these commands :

sudo openvpn --config file.tcp.ovpn

then my authorization

Enter Auth Username: user_xy

and

Enter Auth Password: *********

everything seems fine and terminal prints "Initialization Sequence Completed".

I found out if my router is in "Bridge mode" the openVPN works correctly, but if i set the "Gateway mode" openvpn does not work. I also use VPN application on my mobile phone (it is not openVPN but "TURBO-VPN") and there all works great with both router mode. I have requirement that I need the gateway mode on my router because of NAT.

additional information :

The modes on router set over http here :

enter image description here

  • In the router you should select "Gateway". Than read the contents of you file less file.tcp.ovpn. You need to find out the Protocol Type - in your case TCP i guess - and the Protocol Port. When u have these informaiton you have to create firewall / nat rules in your router. – AlexOnLinux Feb 10 at 15:57
0

You have to create NAT rules on your router. Looking on this scenario from internet perspective, create forward port TCP/UDP 1194 TO your computer inside local network (LAN). You need to tell your router, what to actually do with such traffic. That would be something like:

far OpenVPN peer -> internet -> your router -> forward UDP/TCP port 1194 packets to -> your computer inside LAN (eg. 192.168.1.5) 

Make also sure that such traffic is allowed on the firewall (if is enabled).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.