-1

I'm finding this by using the command systemctl status ssh, and I get a report of (dead). My networking seems to be fine as ping 8.8.8.8 gets responses. Somewhere online I saw a similar problem where it was suggested to try grep sshd /var/log/auth.log. The logs for today are as follows:

Jan 25 20:28:48 RTIBUSDock sudo:     root : TTY=unknown ; PWD=/home/scripts ; USER=root ; COMMAND=/usr/sbin/service ssh start
Jan 25 20:28:49 RTIBUSDock sshd[580]: error: Bind to port 22 on 0.0.0.0 failed: Address already in use.
Jan 25 20:28:49 RTIBUSDock sshd[580]: error: Bind to port 22 on :: failed: Address already in use.
Jan 25 20:28:49 RTIBUSDock sshd[580]: fatal: Cannot bind any address.
Jan 25 20:49:23 RTIBUSDock sshd[1255]: Server listening on 0.0.0.0 port 22.
Jan 25 20:49:23 RTIBUSDock sshd[1255]: Server listening on :: port 22.
Jan 25 20:54:20 RTIBUSDock sudo:     root : TTY=ttySAC2 ; PWD=/root ; USER=root ; COMMAND=/bin/systemctl enable ssh
Jan 25 20:54:30 RTIBUSDock sshd[1255]: Received signal 15; terminating.
Jan 25 20:56:04 RTIBUSDock sudo:     root : TTY=ttySAC2 ; PWD=/root ; USER=root ; COMMAND=/bin/systemctl enable ssh.socket
Jan 25 21:00:52 RTIBUSDock sshd[1020]: Server listening on 0.0.0.0 port 22.
Jan 25 21:00:52 RTIBUSDock sshd[1020]: Server listening on :: port 22.
Jan 25 21:01:08 RTIBUSDock sshd[1020]: Received signal 15; terminating.
Jan 25 21:58:01 RTIBUSDock sshd[826]: Server listening on 0.0.0.0 port 22.
Jan 25 21:58:01 RTIBUSDock sshd[826]: Server listening on :: port 22.

This all started happening after moving the boot volume (on an SD card) from one computer to another.

  • Possible firewall problem... – LinuxSecurityFreak Jan 26 at 1:25
  • Very good idea, thank you. I'll try running it on another network and report back. I forgot to mention that when I sudo service ssh start it comes off without a hitch. Does that mean anything about firewalls? – Bo Thompson Jan 26 at 1:33
  • When moving from one computer to another you may also encounter issues that arise from devices not coming up or not becoming ready when they once did. Or the drivers are getting switched when the service is looking to use a device and it appears busy. – Michael Prokopec Jan 26 at 2:09
1

Fixed using apt-get purge openssh-server && apt-get install openssh-server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.