2

I have struggled to find an answer to this, so I wanted to share what I came up with. In my 32-bit wine prefix on Fedora 29, I have been unable to enable audio. I installed the wine-pulseaudio and wine-alsa packages, yet in winecfg no audio driver appears. Additionally, in winetricks the settings menu shows no sound settings at all! Why is this, and how do I enable audio?

2

It turns out that a 32-bit wine prefix will require the 32-bit version of the drivers. By default, on a 64-bit system, dnf install wine-pulseaudio will install the wine-pulseaudio.x86_64 package. To enable audio in wine I succeeded only after running dnf install wine-pulseaudio.i686. After that, everything went smoothly. Obvious in hindsight, but I thought I'd share in case anybody else runs into the same issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.