0

I have a linux car player. I need to find language files for this device, device have too many menus but onyl have english and chinese language. I can not find any file or folder about language; lang, language, english, chinese eg. check device video here :https://www.youtube.com/watch?v=1FQJ6_WvaZg

I think, I serached wrong drives. May this device have another drives. I did check drives with lsblk command. You can see ls command output and lsbkl command output in below.

Can I sure lsblk command show all drives for this device ? What is mmcblk0 drive ? how can I see files for this unlabeled drive ? Also mmcblk0boot0 and mmcblk0boot1 ?

root@dra7xx-g5-r1:/# ls
bin         home        media       proc        svp         var
boot        include     mnt         run         sys         var.tar
dev         lib         mtp         sbin        tmp
etc         lost+found  opt         storage     usr


root@dra7xx-g5-r1:/# lsblk
NAME         MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
mmcblk0boot0 179:8    0    4M  1 disk
mmcblk0boot1 179:16   0    4M  1 disk
mmcblk0      179:0    0  1.8G  0 disk
|-mmcblk0p1  179:1    0  302M  0 part /
|-mmcblk0p2  179:2    0  516M  0 part /svp
|-mmcblk0p3  179:3    0  182M  0 part /storage
`-mmcblk0p4  179:4    0   78M  0 part /storage/data

root@dra7xx-g5-r1:/# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root               223.4M    204.6M     14.3M  93% /
devtmpfs                444.0M     12.0K    444.0M   0% /dev
tmpfs                    32.0M    636.0K     31.4M   2% /tmp
tmpfs                    16.0M         0     16.0M   0% /media
tmpfs                    16.0M    748.0K     15.3M   5% /var
tmpfs                    32.0M         0     32.0M   0% /mtp
tmpfs                   504.1M         0    504.1M   0% /run
/dev/mmcblk0p3          172.2M     68.9M     90.6M  43% /storage
/dev/mmcblk0p2          491.9M    184.4M    271.4M  40% /svp
/dev/mmcblk0p4           71.5M      9.0M     57.1M  14% /storage/data

during on booting.

U-Boot SPL 2014.07-00209-g36d39ae (Dec 07 2017 - 14:12:00)
DRA722-GP ES1.0
Board identified, using 0 entries B(60) C(60)
Get: magic=0x81488148 flag=0x00000000

 starting kernel ...
[    0.000000] GIC CPU mask not found - kernel will fail to boot.
[    0.000000] GIC CPU mask not found - kernel will fail to boot.
[    0.018988] /cpus/cpu@0 missing clock-frequency property
[    0.499184] ak8859 2-0044: failed to get 8859 video status ERR 0
[    0.505343] ak8859 2-0044: Camera not connected
[    0.514551] omap_voltdm 4a0025cc.voltdm: Unable to get vdd regulator:-517
[    0.521441] coproc iva_coproc: coproc clock notifier not ready, retry
[    0.528103] omap_voltdm 4a0025e0.voltdm: Unable to get vdd regulator:-517
[    0.535517] coproc dsp_coproc: coproc clock notifier not ready, retry
[    0.584878] omap-sham 4b101000.sham: initialization failed.
[    0.601248] dra7xx-mib2-card mib2_sound@0: mclk not found -2.
[    0.612235] omap_voltdm 4a003b20.voltdm: Unable to get vdd regulator:-517
[    0.619062] cpu cpu0: cpu0 clock notifier not ready, retry
[    0.699935] prom_parse: Bad cell count for /ocp/i2c@48070000/tps65917@58
[    0.720371] prom_parse: Bad cell count for /ocp/i2c@48070000/tps65917@58
Hello g5
OSRVC:MSG:rvc_os build Dec  7 2017 14:12:14
OS:svapi:set gfx 8 success and value = 255,svapi_set_gfx_mode,421,pid = 948.
OSRVC:MSG:OSRVC: rvc_os_queue_config
OS:svapi:svapi_gamma_get
OS:svapi:svapi_gamma_get gamma_curve_number = 7,done.
OS:svapi:svapi_gamma_set
OSRVC:MSG:receive sigal cmd 0, on_off 1
OSRVC:MSG:OSRVC: stop RVC, rvc_service_startup_status=0
OSRVC:MSG:set alpha=255,alpha_vid2 = 255.
OS:svapi:set gfx 8 success and value = 255,svapi_set_gfx_mode,421,pid = 948.
OS:svapi:set vid 8 success.
OSRVC:MSG:stop_signal: change video order to 0,rvc_service_startup_status=0
OSRVC:ERR:rvc data link run,thread id = 3068421232.
MSG:vip-vpe-display,disp_kms_open,938: disp_kms_open starting

MSG:vip-vpe-display,disp_kms_open,969: using 1 connectors, 800x480 display, multiplanar: 1
MSG:vip-vpe-display,os_vip_init,671: os_vip_init success!!!
the size of the rollback is 36
OSRVC:ERR:YY:update_flag = 0x0.
OSRVC:MSG:thread_display_logo_entrance start****logo_rvc_status = -1,thread id = 3051644016
MSG:vip-vpe-display,disp_kms_open,938: disp_kms_open starting

MSG:vip-vpe-display,disp_kms_open,969: using 1 connectors, 800x480 display, multiplanar: 1
OSRVC:MSG:thread_display_radar_entrance radar_display->get_gfx_buffers
MSG:vip-vpe-display,os_vip_open,533: os_vip_open success!!!
MSG:vip-vpe-display,os_vip_config,196: vip: G_FMT(start): width = 720, height = 288, 4cc = YUYV

MSG:vip-vpe-display,os_vip_config,209: vip: allocated buffers = 6

OS:svapi:svapi_exlap_logo_get done
MSG:vip-vpe-display,os_vpe_set_crop,160: crop params:vpe->crop.c.height = 288

MSG:vip-vpe-display,os_vpe_set_crop,167: setting  crop params done!

MSG:vip-vpe-display,os_vpe_input_config,283: vpe i/p: allocated buffers = 6

MSG:vip-vpe-display,post_vid_buffer,456: start rvc first frame,thread id = 0xb5e46470.
OS:svapi:set gfx 8 success and value = 0,svapi_set_gfx_mode,421,pid = 948.
OSRVC:MSG:svapi_set_gfx_mode 354
INIT: version 2.88 booting
0
Starting udev
Starting syslogd/klogd: done
update-rc.d: /etc/init.d/run-postinsts exists during rc.d purge (continuing)
INIT: Entering runlevel: 5up links for run-postins
Configuring network interfaces... done.
Starting system message bus: dbus.
logo_remove
not need to load firmware
failed to load module: /usr/lib/gbm/gbm_dri.so: cannot open shared object file: No such file or directory
failed to load module: /usr/lib/gbm/gbm_gallium_drm.so: cannot open shared object file: No such file or directory
loaded module: gbm_pvr.so
PVR: Hint: Setting PDSFragBufferSize to 1024000

PVR: Hint: Setting ParamBufferSize to 0

PVR:(Warning): PVRSRVOpenDCDevice: Warning - 138 returned [80, /bridged_pvr_dc_glue.c]
Starting system PulseAudio Daemon
insmod usb module driver
Wed Jan  1 12:00:00 CST 2014
SYSTEM_VERSION    :MIB2-C-V18-20171207
KERNEL_VERSION    :MIB2-C-V18-20171207
U-BOOT_VERSION    :MIB2-C-V15-20170811
SYSTEM_BUILD_DATE :2017-12-07 14:13:39+08:00
Starting HMI
mount: can't find /storage/data in /etc/fstab
[SVP] SVP_VERSION    :SVP30.6@C1
[SVP] SVP_BUILD_DATE :2017-04-18 17:35:00+08:00
[SVP] Starting ...
[SVP] Clear tmp data.
[SVP] Setup ENV for Normal Boot-Up ...
[SVP] mount return 0...
[SVP] Create cgroups ...
[SVP] Starting Service - "persistservice"
[SVP] Starting Service - "devicemgr"
[SVP] Starting Service - "audiomgr"
[SVP] Starting Service - "powermgr"
[SVP] Starting Service - "sourcemgr"
[SVP] Starting Service - "ilmservice"
[SVP] Starting Service - "appmgr"
powerctrl.
[SVP] Starting Service - "cameraservice"
[SVP] Starting Service - "canservice"
[SVP] Starting Service - "tunerservice"
[SVP] Starting Service - "auxservice"
[SVP] Starting Service - "btservice"
[SVP] Starting Service - "mediaservice"
[SVP] Starting Service - "ipodservice"
[SVP] Starting Service - "exlapservice"
[SVP] Starting Service - "promptservice"
[SVP] Starting Service - "file-explorerservice"
[SVP] Starting Service - "updateservice"
[SVP] Starting Service - "engineeringservice"
[SVP] Starting Service - "mdnsd"
[SVP] Starting Service - "carplayservice"
[SVP] Starting Service - "carlifeservice"
[SVP] Starting Service - "mirrorlinkservice"
[SVP] Starting Service - "connectionservice"
[SVP] Starting Service - "miniplayerservice"
[SVP] Drop caches.
(1217|0xB6F43000) [app-utils] INFO: SVP_StartApp(APP_PLATFORM_CONST_VPANEL, StartInShell, 1, 1)
[    3.626812]
[    3.626812]  mcu_spi radio sync fail......error...
[    3.626812]
(1177|0xB6F0E000) [powerctrl] INFO: SetPowerState() - PS_FIRST_CONNECT_COMPLETE, 0x00
(1184|0xB5DA2460) [sourcemgr] INFO: SetSourceStatus() - src_id (3): SID_AUX_0, src_status: SS_DETACHED
(1184|0xB4DA2460) [sourcemgr] INFO: SetSourceStatus() - src_id (3): SID_AUX_0, src_status: SS_DETACHED
(1217|0xB6F43000) [libapp] INFO: StartApp()- app_id: 12, mode: StartInShell request_type:1 display_pri: 1 option:
(1310|0xB6F95000) [app-utils] INFO: SVP_StartApp(APP_PLATFORM_CONST_STATUSBAR, StartInShell, 1, 0)
(1310|0xB6F95000) [libapp] INFO: StartApp()- app_id: 13, mode: StartInShell request_type:1 display_pri: 0 option:
(1314|0xB6F6A000) [app-utils] INFO: SVP_StartApp(APP_PLATFORM_CONST_TIP, StartInShell, 1, 0)
(1314|0xB6F6A000) [libapp] INFO: StartApp()- app_id: 16, mode: StartInShell request_type:1 display_pri: 0 option:
(1319|0xB6F20000) [app-utils] INFO: SVP_StartApp(APP_PLATFORM_CONST_LAUNCHER, StartInShell, 1, 1)
(1319|0xB6F20000) [libapp] INFO: StartApp()- app_id: 14, mode: StartInShell request_type:1 display_pri: 1 option:
BGW: >>>>>>>>>>>> close btlog
BGW: BtOnOff(1), BtCountryLimitation(1), BtPhone(1), BtAudio(1), BtMultiMedia(1)
(1328|0xB6FAB000) [app-utils] INFO: SVP_StartApp(APP_PLATFORM_CONST_CAMERA, StartInShell, 1, 0)
(1328|0xB6FAB000) [libapp] INFO: StartApp()- app_id: 18, mode: StartInShell request_type:1 display_pri: 0 option:
btservice|vs - Setting_ClearRequestList
btservice|vs - Setting_State_IDLE
btservice|vs - SMS_State_WaitReuqest
btservice|vs - Update_State_Wait
btservice|vs - Music_State_Wait
btservice|vs - Music_Timer_Stop
btservice|vs - Connect_ClearCLInfos
btservice|vs - Connect_State_Wait
BGW: vs_SetCLStatus(0)

dra7xx-g5-r1 login: PVR: Hint: Setting PDSFragBufferSize to 1024000

PVR: Hint: Setting ParamBufferSize to 0

PVR:(Warning): LoadWSModule: Window system module libpvrws_KMS.so did not validate native display [98, /generic_ws.c]
PVR:(Warning): PVRSRVOpenDCDevice: Warning - 138 returned [80, /bridged_pvr_dc_glue.c]
(1184|0xB4DA2460) [sourcemgr] INFO: SetSourceStatus() - src_id (34): SID_CARLIFE_MEDIA, src_status: SS_DETACHED
(1184|0xB45A2460) [sourcemgr] INFO: SetSourceStatus() - src_id (35): SID_CARLIFE_NAVI, src_status: SS_DETACHED
(1184|0xB55A2460) [sourcemgr] INFO: SetSourceStatus() - src_id (36): SID_CARLIFE_PROMPT, src_status: SS_DETACHED
(1184|0xB55A2460) [sourcemgr] INFO: SetSourceStatus() - src_id (37): SID_CARLI
  • What do you mean by 'car player'? And can you explain in more detail exactly what you are trying to do with it? – Time4Tea Jan 25 at 19:54
  • Ok. And what is it you're trying to do with the language files? – Time4Tea Jan 25 at 19:59
  • As Ljm Dullaart says in the comments to their answer, the language is most likely something that is controlled by the 'car player' application itself. I don't think you will be able to change it by simply browsing through the Linux filesystem and changing language files. You would need very in-depth knowledge of how the application works 'under the hood' and most likely the language is governed by some application-specific files or libraries. – Time4Tea Jan 25 at 20:11
  • I think your best bet is to contact the manufacturer of the device and see if they can provide a software update or module that includes the language you need. – Time4Tea Jan 25 at 20:12
  • thank you for your answers, but some users did change language with this way (usb ttl connection with putty), its copy only some changed language files. may be one or more files. i dont know. – g770like Jan 25 at 20:19
1

Most of the language files are in /usr/lib/locale or /usr/share/locale, depending a bit on the distribution used.

lsblk gave you the list of the drives and the place where they are mounted. If you really want to know, mmcblk0p1 is the "drive" where the language files should be.

I would however suggest that you search for "beginners introduction linux command line" in google before you start changing things as root.

  • 1
    Blurting out some output of a random command as comment is quite useless. So, what does ls /usr/lib/local and ls /usr/share/locale say? – Ljm Dullaart Jan 25 at 19:06
  • 1
    If you really want to see all the files in mmcblk0p1, use find / -mount. – Ljm Dullaart Jan 25 at 19:08
  • Ah,, your player uses busybox. ok, then it is find / -xdev – Ljm Dullaart Jan 25 at 19:11
  • Note that the easiest way to see if the Linux system locales are installed would probbably be find / -name en and do an ls of the directory where the en is found – Ljm Dullaart Jan 25 at 19:16
  • 2
    But your car-audio application may have its own language files. And searching for them may be a challenge. Also, you would probably need a language file specially for that application. – Ljm Dullaart Jan 25 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.