I am using a special configuration of monitors on some computers with two monitors. On old setup with NVidia graphics card I used xorg.conf with two screens setup. I was able to start different windows managers on each monitor, because one was DISPLAY :0.0 and another was DISPLAY :0.1.

Now I try to migrate from CentOS5 to CentOS7 and also computers have onboard Intel graphics instead of NVidia.

Whatever I try I only get DISPLAY :0.0. xdpyinfo says that the number of screens is 1 and dimensions of that screen are combined dimensions of both monitors.

There is no more xorg.conf in CentOS7. I would rather use /etc/X11/xorg.conf.d/ directory where I could put parts of xorg.conf, which are special.

How could I start xorg in that way that each separate screens and not one combined display? I want screens :0.0 and :0.1.

I used some xrandr commands to rotate one of the screen, etc. Can I add as display with xrandr?

  • I usually just use something like xrandr --output DP2 --mode 1920x1200 --above eDP1, where eDP1 is my laptop's screen and DP2 is the external monitor.
    – choroba
    Jan 18, 2019 at 13:43
  • 1
    I have no problems displaying graphics on both screens. I want them to be separate screens (:0.0, :0.1) to be able to run different windows managers on them and that windows could not be moved from one screen to another. I have tried xrandr commands as you suggested and they do not provide what I need.
    – nobody
    Jan 18, 2019 at 13:49
  • Oh, I see. Unfortunately, I've never tried that with xrandr :-(
    – choroba
    Jan 18, 2019 at 14:07
  • I used ZaphodHeads option a while ago and I don't know whether this still works. I will try it.
    – nobody
    Jan 18, 2019 at 15:13
  • I suspect the screens are being combined by a feature called "xinerama". I suggest checking for that. And if it is on, turn it off.
    – David G.
    Dec 6, 2020 at 0:17

1 Answer 1


I have found a solution here https://askubuntu.com/a/419614/217214. There is one thing to be careful of. xrandr reports HDMI-1, HDMI-2 and eDP-1 outputs on my graphics adapter. However, I had to use HDMI1, HDMI2 and eDP1 in xorg.conf file.

I did not use /etc/X11/xorg.conf file. I added a file 20-screens.conf to /etc/X11/xorg.conf.d/ directory. The file is very similar to the one provided in the solution https://askubuntu.com/a/419614/217214. So I don't see the point of repeating it here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.