3

I found the systemd-journald takes like 1GB+ of memory. After some searching I set the value of SystemMaxUse and RuntimeMaxUse both to 8M in "/etc/systemd/journald.conf". Then restart the journald.

After a while I found that limit doesn't work, check through 'top' and procstat.memory_rss, the systemd-journald still consumes 100+M after a while (Below is the visualization of journald memory catch through procstat.memory_rss). Any idea?

My systemd version is 219.

enter image description here

  • Yep, it does grab a lot of RAM. – K7AAY Jan 24 at 23:37
1

Both SystemMaxUse and RuntimeMaxUse control disk space usage not memory usage. RuntimeMaxUse does apply to logs on the volatile file system (/run) but thats not captured by procstat.memory_rss Further neither of those options constrain active log files only archived ones.

If journald really is using a GB I would take a serious look at whats creating all of those logs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.