I'm working with a Debian GNU/Linux 7.5 (wheezy)

When I check the file /etc/apt/sources.list The file has this line:

# Line commented out by installer because it failed to verify:
#deb http://security.debian.org/ wheezy/updates main

I tried to replaces for another repo line, but each time I replace it and run the command apt-get update after a while, I get:

E: Some index files failed to download. They have been ignored, or old ones used instead.

What should I do to solve this problem?


2 Answers 2


EDIT: You maybe able to follow the advice in this linuxquestions thread and uncomment the relevant entries in your sources.list and try to run apt update.

Debian 7 reached EOL as of May 31, 2018. Those repositories are no longer active. You can still receive support for Wheezy but it is going to be a lot less painful and expensive on your part to make moves to migrate to Jessie or even Stretch.

On the Debian Wiki there is advice on what to do now that Debian Wheezy is EOL. You may also want to check out this entry to get more information on what to do.

If you are upgrading to Jessie, your sources.list needs to changed to the following:

deb http://deb.debian.org/debian/ jessie main contrib non-free
deb-src http://deb.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://deb.debian.org/debian/ jessie-updates main contrib non-free

Then run apt update, apt install apt -t jessie, apt upgrade, and finally apt-get dist-upgrade to update and upgrade to Jessie.

If you absolutely need to stay on Wheezy and cannot change to Jessie, either due to issues outlined here or because of some other limitations on your environment then you may need to change over to the archive mirrors or look into paid ELTS support.

Archive mirrors will look something like this:

deb http://archive.debian.org/debian/ wheezy main contrib non-free
  • apt dist-upgrade faild for me with an unmet dependency on plymouth. An apt-get install udev plymouth followed by a apt dist-upgrade solved it for me.
    – KIC
    Jun 7, 2019 at 8:57
  • Note, latest release is now buster. I managed to dist-upgrade all the way from wheezy to this (I went release by release so it was quite long winded) but it worked fine because Debian is so amazing.
    – John Hunt
    Nov 6, 2019 at 13:42
  • 1
    I want to add one more note. Most probably after changins sources.list and running apt-get update you will get error There is no public key available for the following key IDs: 1397BC53640DB551 Which should be solved like this sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1397BC53640DB551 (don't forget to change your hash). Original answer from askubuntu.com/questions/766883/… Nov 12, 2019 at 10:00

has some information on it, about updating it to (there must be "main" at the end):

deb http://security.debian.org/debian-security wheezy/updates main

  • 3
    This does not work - wheezy is too old for Debian security
    – Chris
    Jul 26, 2019 at 6:24

Not the answer you're looking for? Browse other questions tagged .