0

I installed arch a day ago and it was fine until yesterday but after I changed some settings in the /etc/pam.d/system-local-login to use fingerprint login and reboot, I can't login in to arch linux. So I used my bootable usb to get into arch and changed the root password and tried deleting the user and making it again but nothing seems to work. Also I can now login in the bootable usb but cannot login with the same password when I boot normally.

Also, the /etc/pam.d/system-local-login doesn't seem to be changed even though I thought I changed it. What should I do?

I am using gnome

  • Just to make sure that you are doing this right. Have you tried the methods provided in Arch Wiki when it comes to resetting the root password? You are using fprint for this, am I right? Have you tried your new password in TTY? – Gilgamatic Jan 23 at 6:21
  • Yes I tried like the wiki but it didn't work :( – HyeonseokJung Jan 23 at 7:35
  • @HyeonseokJung, did you do the MOUNT before you tried to change the password ? – jayooin Jan 23 at 9:17
  • Sorry for the late reply well yes I did mount the partition to /mnt and did the changes inside arch-chroot. I tried to solve the problem but I just reinstalled arch after all – HyeonseokJung Jan 24 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.