0

In a specific directory, if I right click and select "Open Terminal". It just launches another instance of the terminal in the root location and not the location where I intended it to open.

Is there a workaround for this. I want to be able to Open a terminal in a specific location and attach it as a new split/window in an already running byobu terminal.

For additional info : I added "byobu" to my .bashrc file so that whenever I open a terminal byobu process also starts. I'm running the default file Manager of Ubuntu 18.04

  • Edited the question – 100rabh Jan 22 '19 at 7:31
1

I found a way to also avoid having to type "byobu" in every terminal window, in case anyone else has this problem. Just add the following three lines to your .bashrc:

byobu kill-session -a

byobu new-session -c $PWD

byobu

Or, if you just want to add windows rather than killing and respawning entire sessions, you can instead use:

byobu new-window -c $PWD

byobu

0

So to simply circumvent the problem, I removed "byobu" from .bashrc. So byoubu wont be enabled by default.

Now when I R-click and open in terminal it should open terminal from that specific directory. If I want I'll just type "byobu" from there on.

Its a stupid Question and a simple answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.