1

I've Zathura as my default pdf viewer which is fine. I've also installed Foxit Reader but it doesn't show up when I try to open any pdf file in ranger with r key. I tried adding following line in my rifle.conf file:

ext pdf, has FoxitReader X, flag f = FoxitReader -- "$@"

I'm able to open any pdf file with FoxitReader myfile.pdf command.

But still, I'm not able to see Foxit as an option in ranger! I'm not sure what's wrong with the edit I made to my rifle.conf file.

0

So, the issue was in the syntax. I was missing a , after FoxitReader and -- was throwing an error. Following line works:

ext pdf, has FoxitReader, X, flag f = FoxitReader "$@"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.