1

I am doing a project with EV3 (Lego Mindstorms).

Currently my workflow requires saving the file, transferring it, compiling it and finally run it.

This takes too much time and I wanted to improve it.

That's why I want to use unison to allow two-way sync over my computer and the remote machine.

Now, the problem is that via brew install unison it installs unison 2.51.2, and via apt-get on the EV3DEV (debian-linux) it installs unison 2.40, which is incompatible.

Apparently 2.51.2 is unsupported for debian-linux, so this means that somehow I need to downgrade the MacOS version, problem is that brew offers only 2.51.2 .

Note: I already tried to install brew, but the brew installation Cannot find a vendored version of ruby for your armv5tejl.

  • Weclome , you can install brew on debian. Linuxbrew – GAD3R Jan 19 at 16:05
  • 1
    @GAD3R Thank you. Unfortunately I already tried to but the brew installation Cannot find a vendored version of ruby for your armv5tejl – A. Dandelion Jan 19 at 16:06
  • As of January 19, Unison 2.51 is in beta. The latest stable release, which I would recommend, is 2.48. source I think your best path would be version 2.40 on both computers. Is it possible to install an older version via Brew? – bitinerant Jan 19 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.