0

This issues is on Manjaro Deepin 15.9 linux DE. When I run java -version in terminal it outputs this:

Picked up _JAVA_OPTIONS:    
java version "11.0.2" 2019-01-15 LTS     
Java(TM) SE Runtime Environment 18.9 (build 11.0.2+9-LTS)    
Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.2+9-LTS, mixed mode)

But if the command is run with sudo it outputs it normal without the Picked up _JAVA_OPTIONS: message !

I managed by placing unset JAVA_OPTIONS in /etc/environment , /etc/profile and ~.bashrc to remove the message from terminal. But the message still shows up in Netbeans when I run a project.

Also I run Netbeans as sudo just to check will it show then and it didn’t. I tried removing some software from Linux which I didn’t need or believe made it was causing the message (because I read the few posts about software being an issue), but nothing changed.

Message not showing in sudo makes me believe maybe root user doesn’t have something installed that normal user has which is producing this message.

This message is visible in live preview of Manjaro Deepin on bootable usb!

  • does your regular user have java aliased or otherwise wrapped in a function or script? type -a java would clarify. – Jeff Schaller Jan 19 at 17:12
  • @Pierre.Vriens it does not have, here's the output of the command java is /usr/lib/jvm/default/bin/java java is /usr/bin/java java is /bin/java java is /usr/lib/jvm/default/bin/java – J.DoeDoeJ Jan 19 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.