1

I have been following this tutorial to install ELK stack in a remote server which runs on Amazon Linux. https://www.aytech.ca/blog/setup-elk-stack-amazon-linux/
I was able to install Elasticsearch and then to start it as a service.Then I installed logstash. However when I try to start the logstash service using this command,

service logstash status 

the console returns this error.

 logstash: unrecognized service

However, when I grep'd the logstash it gave this output. Means it is running,right?
enter image description here

Can someone provide a solution how to make this logstash run as a service?

enter image description here

  • 1
    so the similar command service elasticsearch start worked just fine? – Jeff Schaller Jan 18 at 16:57
  • @JeffSchaller I added a screenshot of outputs to those two commands to the question. – evilMinion Jan 21 at 8:50
  • 1
    This guide might refer to Amazon Linux 1 and if you launched an instance recently you might have launched Amazon Linux 2, can you try running systemctl status logstash and see what is the output in that case. – Yaron Jan 21 at 9:40
  • @Yaron I tried running that and it gave me -bash: systemctl: command not found. – evilMinion Jan 21 at 10:53
  • 2
    is there anything logstash-related in /etc/init.d? – Jeff Schaller Jan 21 at 13:09
0

Eventually I had to relaunch the server with Amazon Linux 2 OS.Now I am able to run Logstash inside that,but I still don't know how to tackle the issue in an Amazon Linux 1 OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.