0

I have installed Trader WorkStation by Interactive Brokers. However, the program does not run, with assistance from support I found that the firewall is the problem.

The servers (several primary and backup servers) listen on port 4000 and 4001 (in case of SSL connection). The site recommends the following command for testing:

telnet zdc1.ibllc.com 4000

If I try to run that, I get

Trying 217.192.86.32...
telnet: connect to address 217.192.86.32: Connection timed out

I already tried to activate the port:

$ firewall-cmd --list-ports
1025-65535/udp 1025-65535/tcp
$ firewall-cmd --zone=public --add-port=4000/tcp --permanent
success
$ firewall-cmd --reload
success

The testing is still negative. Connection timed out.

How can I open the port? It would be ideal to restrict the access only to a few servers that are mentioned on the site. I have Fedora 27. Thank you.

EDIT (Solved): Thanks to @mark-plotnick. The problem was in the settings of the router - when I connect elsewhere, the connection works. As I will move in a few days, it's not necessary to open the ports in the router.

  • Fedora typically allows all outgoing connections. Do you have one or more routers to go through before you get to your ISP? They may have firewall rules, too. Does traceroute zdc1.ibllc.com succeed? – Mark Plotnick Jan 17 at 2:05
  • No, it fails. I get only to the first hop ` 1 gateway (192.168.0.1) 2.662 ms 5.300 ms 5.254 ms` followed by asterisks only. Is the problem within my router? – neydek Jan 17 at 21:02
1

I don't use Fedora, but according to the documentation:

List all open ports for a zone, for example dmz, by entering the following command as root:

# firewall-cmd --zone=dmz --list-ports

To add a port to a zone, for example to allow TCP traffic to port 8080 to the dmz zone, enter the following command as root:

# firewall-cmd --zone=dmz --add-port=8080/tcp

To make this setting permanent, add the --permanent option and reload the firewall. To add a range of ports to a zone, for example to allow the ports from 5060 to 5061 to the public zone, enter the following command as root:

# firewall-cmd --zone=public --add-port=5060-5061/udp

To make this setting permanent, add the --permanent option and reload the firewall.

That should be a good first pass on getting IB to work. For what it's worth, this was the first search result for "fedora open ports".

  • I already tried this but with no results. $ firewall-cmd --list-ports 1025-65535/udp 1025-65535/tcp – neydek Jan 16 at 23:18
  • @neydek That (and anything else you've tried) should be included in your original question then. – Michael A Jan 16 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.