0

I've been having an issue with my first installation of FreeBSD. As I always do in GNU/Linux I created separate home and root partitions. The issue I've been having is that my home partition doesn't mount.

Luckily, when boot fails it just dumps me at a root prompt but unfortunately after remounting / as read-write and not just read only, I can't mount /dev/ada0p3, my /home partition, as /home, or as anything else.

The exact error I get is mount /dev/ada0p3: No such file or directory, and yet a quick ls /dev/ shows me that ada0p3 is indeed there, and gpart show confirms that partition 3 on device ada0 is freebsd-zfs and is 185GB, the size I allocated for my home.

I'm using zfs for both / and /home.

This is a fresh install, so if need be I have no qualms with nuking the drive and reinstalling, but I'd prefer to avoid spending more time on this than I have to.

  • 2
    ZFS mounts are performed using zfs command. – arrowd Jan 17 at 7:07
  • How are you installing FreeBSD? The Auto (ZFS) option already creates separate datasets for / and /usr/home and several others. – Richard Smith Jan 17 at 9:37
  • If ada0p3 is type freebsd-zfs then it is likely a member of a zpool, not a directly mountable filesystem. Please edit your post to include the output of zpool status and zfs list. While you're at it, throw in zfs get -t filesystem canmount,mountpoint. :) – Jim L. Feb 1 at 22:00
1

Try zfs mount -a. If this doesn't work, check the following zfs get mountpoint,canmount hostjails tank/home or tank/usr/home depending on your pool name and dataset location

mountpoint should be defined to a folder like /home and canmount should be on

If that is not the case you can fix it with zfs set canmount=on tank/home for example, similarly to mountpoint.

Please ensure the mountpoint folder exists before trying to mount.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.