0

I'm working with a custom made image of Slackware ARM 14.1 with kernel 3.8.X since about 3 years and now needed to upgrade kernel for cdc-acm driver and watchdog.

I've tried different kernels from distro supplied with BeagleBone (Debian 7.11 to 9.5, kernel 4.1.X to 4.14.X). Each time I replace files in /boot/ and /lib/modules and /lib/firmware, they are all booting properly but never been able to make UART working again.

With kernel 3.8.X, I was using /boot/uEnv.txt line :

optargs=capemgr.enable_partno=BB-UART1,BB-UART2,BB-UART4

I know there was changes between 4.1.X and 4.4.X and 4.14.X but tried each configurations with no success. Is it possible the issue is because I have a FAT partition for /boot/ and EXT4 partition for / ? Because I'll have to remote update systems so will not be able to change partitions.

Also could it be possible that the issue is the U-Boot version? From the debug serial :

U-Boot 2014.04-rc2-00015-g99288ca (Mar 12 2014 - 09:49:41)

EDIT :

Updated the U-Boot, still the same issue

U-Boot 2018.09-00002-g0b54a51eee (Sep 10 2018 - 19:41:39 -0500), Build: jenkins-github_Bootloader-Builder-65
0

Finally I used the kernel 4.4.54 from image bone-debian-9.5-iot-armhf-2018-10-07-4gb.img which serial ports work as ttyS? instead of ttyO?.

Something probably wrong with 4.14.X configuration (uEnv.txt or other), but I'm satisfied with 4.4.X for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.