2

I had Linux Debian installed onto my computer. My partition table was as follows:

sda1: __________________________________________________________________________

File system:       vfat
Boot sector type:  FAT32

sda2: __________________________________________________________________________

File system:       ext4
Operating System:  Debian GNU/Linux buster/sid

sda4: __________________________________________________________________________

File system:       ext4

On /dev/sda1 I had EFI boot partition, /dev/sda2 was my root (/), and /dev/sda4 was mounted as /home. To install Manjaro Linux, I resized partitions (by GParted) and arrived at the following partition table:

sda1: __________________________________________________________________________

File system:       vfat
Boot sector type:  FAT32

sda2: __________________________________________________________________________

File system:       ext4
Operating System:  Debian GNU/Linux buster/sid

sda3: __________________________________________________________________________

File system:       swap

sda4: __________________________________________________________________________

File system:       ext4

sda5: __________________________________________________________________________

File system:       ext4
Operating System:  Manjaro

As you can see, I added /dev/sda3 as swap partition and /dev/sda5 as a partition where I installed Manjaro. During the installation, I formatted /dev/sda1 (where I booted Debian from) and Manjaro installed its boot files there. After installation, I have two options in GRUB: boot Debian and boot Manjaro. Booting Manjaro is working fine, but booting Debian leads to the Welcome to emergency mode! problem. I am asked to give the root password but after I enter it nothing seems to happen (perhaps I've forgotten the password but there is no message indicating that it is wrong). After some googling, I have come to conclusion that Debian's fstab may be incorrect. Please have a look at it:

# / was on /dev/sda2 during installation
UUID=de26f007-befa-4524-b1c8-059e115aa36c /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
#UUID=B1D2-AC43  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/sda4 during installation
UUID=5c273b54-01ad-4186-9821-1e90980a8913 /home           ext4    defaults        0       2
# swap was on /dev/sda3 during installation
#UUID=9da48f63-2583-4e29-8997-3c6474e4bcbc none            swap    sw              0       0
UUID=ECA5-260F  /boot/efi   vfat    defaults    0   1

What should I do to have my Debian working?

EDIT

  • I've tried what A.B suggested in the comments (i.e. adding /dev/sda2 to grub parameters) but it didn't work.

  • I cannot provide the journalctl -xb as that error message as jdwolf suggested in the comments since Debian after providing root password won't let me in (I cannot login).

  • I tried commenting things out of fstab as thrig suggested in the comments. Now Debian boots to a different mode than emergency mode.

EDIT 2

$ lsblk -f
NAME   FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                     
├─sda1 vfat         5AD2-7533                             510.7M     0% /boot/efi
├─sda2 ext4         de26f007-befa-4524-b1c8-059e115aa36c    5.5G    60% /mnt/sda2
├─sda3 swap         62f96d88-8521-453b-8df7-9c61095ec52c                [SWAP]
├─sda4 ext4         5c273b54-01ad-4186-9821-1e90980a8913   19.5G    71% /run/media/michal/5c273b54-01ad-4186-9821-1e90980a8913
└─sda5 ext4         d6f9b919-1373-4285-81e8-9f0838d660d7      1G    86% /
  • You could try editing (at boot time) the grub boot prompt and add or replace root=/dev/sda2 to the command line just before actually booting Debian. If this works, then well I don't know what else (grub issue?). Also if you did this just at the wrong time when having on Debian udev 240-2 or 240-3 (and not -4) then you hit a systemd/udev bug – A.B Jan 16 at 22:54
  • yeah try commenting things out of fstab, I've seen stray entries therein send Ubuntu boots to sudden systemd emergency mode – thrig Jan 17 at 2:37
  • Why not provide the journalctl -xb as that error message mentions? – jdwolf Jan 17 at 14:50
  • @jdwolf I will do in a couple of hours when I get home. – menteith Jan 17 at 15:13
  • Provide an lsblk -f output – Dmitry Jan 19 at 20:42
1

You should boot your working Linux. After that you try to change root into the Debian system. As root try this (there may be typos):

mount UUID=de26f007-befa-4524-b1c8-059e115aa36c /mnt
mount UUID=5c273b54-01ad-4186-9821-1e90980a8913 /mnt/home
mount UUID=ECA5-260F  /mnt/boot/efi
mount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /run /mnt/run
mount --bind /sys /mnt/sys
chroot /mnt

Inside the debian you can just reset the password of any user with passwd and try to verify fstab (if you did not already).

Don't forget to cleanly unmount this mess ;)

0

You said, you formated the partition you boot Debian from and then put the Manjaro boot files there? Is that correct? If it is, then you overwrote your Debian system with the boot files for Manjaro. There is probably no making that Debian install bootable again..!

  • The reason it hangs when you try to boot Debian, is that Debian is nolonger there. The grub entry is there, because that should be on sda1. However the boot files for Manjaro now reside on sda2 where Debian was, so the system stops.

  • Grub should be instaled on the same partition as the previous grub, and the OS should be installed with the install alongside option.

  • The boot files should be on the root partition of it own OS or a partition not occupied by any other OS that you intend to use.

The only option I can see from the information provided, is to use a data recovery tool to recover what you can from that partition, as the format and relatively small overwrite by the boot files most likely did not destroy all that much data. You might walk away from this with all the files you need, and a good lesson learned. These things happen, that is why the tools to fix them exist, we are all human after all.

0

Are you able to "see" your Debian partition under Manjaro? Can you mount it (preferably read-only) and check that it "looks" OK?

If the answer to both questions is "Yes!", then get the UUID of this partition and give it to the grub command line to ensure that you are booting the correct partition.

If the answer to either question is "No!", then I would go along with Michael Prokopec's answer and declare that you are out of luck.

0

You can not actually rely on GRUBs os-prober to be able to boot Linux of another distribution. There may also be other unknown configuration problems.

From the Manjaro Linux GRUB menu press then press c for the command line.

Type

configfile (hd0,1)/boot/grub/grub.cfg

Which will load the configurations for GRUB over from your Debian install. That should be the most reliable way to make sure your Debian Linux boots correctly given that its own GRUB efi application is not being loaded.

If that works you can then fix it from within Debian by running sudo apt-get install --reinstall grub-efi-amd64 You shouldn't need to but you might as well also update the configuration with update-grub

You then must pick the operating system via the UEFI boot menu not GRUB. If you want a universal bootloader for UEFI try looking into rEFInd.

0

When you formatted SDA1 it got a new UUID and it looks like your Debian fstab can't find /boot/efi when mounting.

Try your fstab as follows. Comment out the swap if Debian was installed without any.

# /boot/efi was ECA5-260F looks wrong
UUID=5AD2-7533  /boot/efi   vfat    defaults    0   1

# / was on de26f007-befa-4524-b1c8-059e115aa36c looks OK
UUID=de26f007-befa-4524-b1c8-059e115aa36c /               ext4    errors=remount-ro 0       1

# /home was on 5c273b54-01ad-4186-9821-1e90980a8913 looks OK
UUID=5c273b54-01ad-4186-9821-1e90980a8913 /home           ext4    defaults        0       2

# swap was 9da48f63-2583-4e29-8997-3c6474e4bcbc looks wrong
# try with and without swap commented
#UUID=62f96d88-8521-453b-8df7-9c61095ec52c none            swap    sw              0       0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.