1

My goal is to install the Server version of Fedora 28.1.1, on a second Intel S1200SPLR server (after the first was proved to have a hardware problem) with a Xeon E3-1275 v5 CPU, 16GB of 2133 Unbuffered ECC DDR4, the onboard Intel P530 integrated HD Graphics, and a 480GB SSD, all components approved by the server board manufacturer. There are no cards in the system.

I am using the directly connected monitor on the only VGA port (back panel) and have specified that in the BIOS/Settings; IPMI is not available to me. I am not familiar with dracut.

First, I tested with Ubuntu 18.04.1 LTS, which installed AOK from its checksummed LiveUSB. There was no lag.

Next, I tried Fedora Server 28.1.1, from a LiveUSB generated by the Fedora LiveUSB Writer. The terminal window went blank shortly after booting from its checksummed LiveUSB. I got the same result with Fedora Workstation 29.1.2. I repeated the attempts with an ISO written onto different flash drives with Rufus.

Pressing e in GRUB2 to replace quiet with nomodeset did not help. Neither did adding inst.text, vga=790, or vga=793 (ref. http://blog.fpmurphy.com/2009/09/project-plymouth.html). Every time, Server 28 stalled at fb: switching to mgag200drmfb from EFI VGA.

Then, to try to get some information about what's happening, I tried Fedora Spin Workstation 29.1.2 with Cinnamon, having remembered something about GNOME problems. It installs, but Cinnamon repeatedly crashes every minute, both in LiveUSB mode and after installation and reboot. Cinnamon reports it is rendering in software mode. The 28.1.1 Spin with Xfce (which uses lightdm) installs and runs OK, which does suggest something in the GNOME package is trouble.

I opened a terminal, and copied dmesg from the Fedora 29.1.2 Workstation Cinnamon install for your review. The results of lspci-k can be seen here, and it appears there's a Matrox display adapter as well as the Intel Integrated HD Graphics on the motherboard..

I have also, as per https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/6/html/deployment_guide/blacklisting_a_module, created /etc/modprobe.d/blacklist.conf which contains one line

blacklist mgag200

and rebooted, but lspci -k still shows the Matrox in use.


I also edited /etc/default/grub to remove quiet rhgb (the call to Red Hat Graphical Boot) and replaced that with inst.text then ran grub2-mkconfig -o /boot/grub2/grub.cfg and rebooted. When I did, I opened up grub with e and found its next to last line read

GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap rd.lvm.lv-fedora/root rd.lvm.lv=fedora/swap rhgb quiet"

I changed that to

GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap rd.lvm.lv-fedora/root rd.lvm.lv=fedora/swap inst.text"

but the problem persisted.

-

Again, my objective is to install Fedora 28.1.1 Server, and the Workstation installs are just an attempt to gather information for troubleshooting.

  • 1
    So what I suspect is going on here is the local framebuffer is switching to the Matrox video adapter right after Plymouth loads. Since you've selected Intel video instead, the screen goes blank at this point. I suggest booting the installation media by removing rhgb and adding inst.text to the kernel command line. This will prevent any switch of video adapter and it should stay (1) in text mode, and (2) on the video adapter you booted with. Though, if you actually do intend to use it as a server I would suggest switching it back to the Matrox so you can use the remote console. – Michael Hampton Jan 17 at 20:17
  • 1
    Hmm. Can you try connecting to the BMC web console instead and seeing what appears there when you boot the system? – Michael Hampton Jan 18 at 18:32
  • 1
    If you never set up the BMC web access before, you'll probably have to do that. Of course since it's a server, I thought you would have done so already. – Michael Hampton Jan 18 at 18:50
  • Will BMC web access provide more information than dmesg did? See drive.google.com/open?id=14N85QxGUX3IkrPcRplHOv_KbRSqxxobX – K7AAY Jan 22 at 17:23
  • Isn't your object to install Fedora Server? I can't say whether you'll get more information, but what you may well get is a working console. Again, I'm quite surprised you haven't already set this up; it's something you should have up and running before you even install an OS. – Michael Hampton Jan 22 at 17:35
2
+50

Which VGA port are you connecting to? Front or back? Make sure you are using the front one. (I am used to a different version of that platform, so I am making a few assumptions here.)

Have you used dracut to rebuild your initramfs?

  • 1
    Also grab the pdf of the manual off intel.com. – Alan Jan 17 at 22:50
  • Linked in first line of question. – K7AAY Jan 17 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.