0

I tried to build a customized nginx with specific nginx version with module in https://github.com/anomalizer/ngx_aws_auth

I setup the nginx repo

# nginx.repo

[nginx]
name=nginx repo
baseurl=http://nginx.org/packages/centos/7/$basearch/
gpgcheck=0
enabled=1

I do see the nginx-1.10.2-1.el7.ngx.src.rpm in "http://nginx.org/packages/centos/7/SRPMS/" and download it with

curl http://nginx.org/packages/centos/7/SRPMS/nginx-1.10.2-1.el7.ngx.src.rpm -o nginx-1.10.2-1.el7.ngx.src.rpm

Yet while I tried to run yum-buildep to install dependencies, I keep getting the error of "No such package(s): nginx-1.10.2-1.el7.ngx.src.rpm". Any idea? Thanks.

yum-builddep --enablerepo=nginx nginx-1.10.2-1.el7.ngx.src.rpm

The output in detail

Loaded plugins: fastestmirror, priorities
Enabling base-source repository
Enabling epel-source repository
Enabling extras-source repository
Enabling updates-source repository
Loading mirror speeds from cached hostfile
 * base: mirrors.cat.pdx.edu
 * epel: mirrors.cat.pdx.edu
 * epel-source: mirrors.cat.pdx.edu
 * extras: mirrors.cat.pdx.edu
 * updates: mirrors.cat.pdx.edu
Checking for new repos for mirrors
No such package(s): nginx-1.10.2-1.el7.ngx.src.rpm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.