0

First i login to my server using putty.

and this is my server data

uname -or

2.6.32-754.6.3.el6.x86_64 GNU/Linux

uname -a

Linux vps-xxx-xxx.example.com 2.6.32-754.6.3.el6.x86_64 #1 SMP Tue Oct 9 17:27:49 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/*elease

CentOS release 6.10 (Final) CentOS release 6.10 (Final) CentOS release 6.10 (Final)

And this is my mysql version.

SELECT VERSION();

5.5.61

And this is mysql user.

select User,Host from mysql.user;

+----------------+-----------+ | User | Host | +----------------+-----------+ | admin_test | % | | admin_test | localhost | | root | localhost | | roundcube | localhost | +----------------+-----------+

Then i tried to change mysql password. 1. service mysqld stop 2. mysqld_safe --skip-grant-tables & 3. mysql 4. UPDATE mysql.user SET Password=PASSWORD('123456qwerty7890') WHERE User='admin_test'; 5. FLUSH PRIVILEGES; 6. exit; 7. mysqladmin -u root -p shutdown 8. service mysqld start Then i tried to access to my phpmyadmin xx.xxx.xxx.xxx/phpmyadmin use username = admin_test and password = 123456qwerty7890

but can not login how can i do ?

  • (1) Is it normal for the user table to have multiple rows for the same user?  (2) What output did the commands give?  (Specifically, the UPDATE command.)  Please do not respond in comments; edit your question to make it clearer and more complete. – G-Man Jan 14 at 7:30
  • 2
    (1) Please don't repost questions.  Click on the edit link at the bottom of the question to add new information. (2) I believe that it's now "obvious" why you can't login with the new password.  Now you need to ask why the UPDATE command said "0 rows affected" and "Changed: 0". – G-Man Jan 14 at 8:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.