1

Bluetoothctl is not detecting my realtek bluetooth controller.

Output of ls /dev | grep hci

vhci

Output of dmesg | grep -i bluetooth

[    3.203531] usb 4-10: Product: Bluetooth Radio 
[    3.689235] Bluetooth: Core ver 2.22
[    3.689259] Bluetooth: HCI device and connection manager initialized
[    3.689264] Bluetooth: HCI socket layer initialized
[    3.689267] Bluetooth: L2CAP socket layer initialized
[    3.689272] Bluetooth: SCO socket layer initialized
[    3.720373] Bluetooth: hci0: RTL: rtl: examining hci_ver=08 hci_rev=826c lmp_ver=08 lmp_subver=a99e
[    3.720377] Bluetooth: hci0: RTL: rtl: unknown IC info, lmp subver a99e, hci rev 826c, hci ver 0008
[   59.402999] audit: type=1130 audit(1547348479.153:37): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=bluetooth comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   59.413396] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   59.413398] Bluetooth: BNEP filters: protocol multicast
[   59.413404] Bluetooth: BNEP socket layer initialized

Output of lsusb

Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 1532:0502 Razer USA, Ltd 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 003: ID 062a:5918 MosArt Semiconductor Corp. 
Bus 004 Device 002: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 004 Device 004: ID 0bda:b00a Realtek Semiconductor Corp. 
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Output of bluetoothctl and then typing power on

No default controller available

The bluetooth service is currently running

I am a member of the lp group

Output of lsmod | grep btusb

btusb                  57344  0
btrtl                  20480  1 btusb
btbcm                  16384  1 btusb
btintel                28672  1 btusb
bluetooth             651264  12 btrtl,btintel,btbcm,bnep,btusb

I have the bluez package installed and I have tried both bluex-utils and bluez-utils-compat

Edit The bluetooth controller hci0 is detected by the kernel but bluetoothctl does not find it.

Does anyone know how to fix this issue?

Edit #2 I have figured out that in hciconfig hci0 is down but if I run hciconfig hci0 up it returns Can't init device hci0: Invalid argument (22)

1 Answer 1

1

Would you happen to have RTL8821CE wireless + bluetooth combo?

There's a solution for Arch about this problem on the AUR package's Github. https://github.com/tomaspinho/rtl8821ce/issues/19#issuecomment-451890849

I'm hoping it's a temporary problem due to some other bug because someone said it began working again. https://bugzilla.kernel.org/show_bug.cgi?id=201921#c1

1
  • The kernel patch that was suggested in that github issue fixed it :)
    – finman
    Commented Jan 13, 2019 at 19:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .