3

I'm using Thunar 1.8.2 on Debian Testing and the "Open Terminal here" function seems buggy.

I've set up the custom action xfce4-terminal --working-directory=%f with the keyboard shortcut F4.

Oddly enough, right-click in Thunar and "Open Terminal here" always seems to work. That opens the xfce4-terminal with the current working directory.

But with F4 it always opens the terminal with the directory I last used the right-click "Open Terminal here".

So for example, in Thunar I go to /tmp/, right-click, "Open Terminal here", I get a Terminal with /tmp/ as the current working directory. I close the terminal, move to /home/ in Thunar, then press F4 and I get a Terminal with /tmp/ as the current working directory again.

How do I fix this behavior?

edit: This is the current configuration: https://i.sstatic.net/Yz6wG.png

6
  • 1
    @GAD3R The command I use works fine. I don't have a full-blown DE like xfce4 so your command results in the following for me: i.imgur.com/rPtWVta.png Commented Jan 12, 2019 at 14:10
  • 1
    I don't have any other shortcut mapped for F4 and I don't have a settings manager. As I said I don't use a DE. Commented Jan 12, 2019 at 14:18
  • 2
    Remove working-directory and keep only xfce4-terminal
    – ctac_
    Commented Jan 12, 2019 at 15:49
  • 1
    @ctac_ oh wow! marvelous! How/why is this the case? Thank you so much! If you want to form an answer, I'll gladly approve it Commented Jan 12, 2019 at 16:41
  • 1
    I think it's like a lot of other program. If you don't give a path, it take the current path. You can try with a custom action like ls > dir.txt and you get a file dir.txt in the current directory.If you want to know more about xfce4-terminal, you can ask here:forum.xfce.org/index.php .
    – ctac_
    Commented Jan 12, 2019 at 17:09

1 Answer 1

0

With Thunar v4.16.10 on Debian Sid, I only use x-terminal-emulator with no %[letter] parameter whatsoever, and it works perfectly.

Notes:

  1. The x-terminal-emulator environment variable is set to /usr/bin/terminator on my system, but it works with rxvt-unicode as well (or urxvt), for instance;
  2. On any Debian-based system, use update-alternatives (as root) to set the default terminal emulator you want to use. It should work with most terminal emulators.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .