2

I'm working on Ubuntu 18.04.

ifconfig
enp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 94:c6:91:1f:49:92  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 116  base 0xa000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 77913  bytes 21803244 (21.8 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 77913  bytes 21803244 (21.8 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.41  netmask 255.255.255.0  broadcast 192.168.1.255
        ether 0c:54:15:a6:a3:5b  txqueuelen 1000  (Ethernet)
        RX packets 78879  bytes 61763037 (61.7 MB)
        RX errors 0  dropped 1  overruns 0  frame 0
        TX packets 44573  bytes 6779824 (6.7 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlx00e02d01076f: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.1  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 fe80::2e0:2dff:fe01:76f  prefixlen 64  scopeid 0x20<link>
        ether 00:e0:2d:01:07:6f  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 6  bytes 485321 (485.3 KB)
        TX errors 0  dropped 145 overruns 0  carrier 0  collisions 0
iwconfig
lo        no wireless extensions.

wlp2s0    IEEE 802.11  ESSID:"CoreFragment_5G"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: 34:0A:98:7A:6C:E0   
          Bit Rate=433.3 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=57/70  Signal level=-53 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2026   Missed beacon:0

enp3s0    no wireless extensions.

wlx00e02d01076f  IEEE 802.11bgn  ESSID:"Aleph_inCar"  Nickname:"<WIFI@REALTEK>"
          Mode:Master  Frequency:2.412 GHz  Access Point: 00:E0:2D:01:07:6F   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
$ cat /etc/hostapd/hostapd.conf
interface=wlx00e02d01076f
#interface=wlxe84e062ffbc2
ssid=Aleph_inCar
channel=1
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=1234567890
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
driver=nl80211
#driver=mt7601u
#driver=cfg802
ieee80211n=1
ieee80211ac=1
hw_mode=g
device_name=RTL8812AU
manufacturer=Realtek

There is nothing wrong,But SSID of hostapd is not visible to any device.

1

iwconfig shows no evidences it is handling that wifi chipset as an ac capable one (either it is not supported, wrong configurations or the driver/hardware does not support the ac protocol). It is only showing 802.11bgn.

As such hostapd is most likely getting confused when trying to configure 802.11ac.

I advise taking out that ieee80211ac=1 and restarting hostapd

PS The Invalid misc:2026 iwconfig output is also a solid clue about an invalid configuration/settings being the culprit.

See related question: Wi-Fi problems using ASUS USB-N13 adapter (realtek)

  • As per your answer it works... But initially it works on both ieee80211n,ieee80211ac. Any technical issue? – Yash Shah Jan 12 at 11:28
  • Wrong driver / configurations / hostapd support... The impression I have got is you using hostapd settings at random, some of them might be mutually exclusive – Rui F Ribeiro Jan 12 at 11:48
  • my in-built wifi is also not working – Yash Shah Jan 12 at 11:54
  • I would advise adding another question for that. I will be offline for a good while – Rui F Ribeiro Jan 12 at 12:03
  • getting same problem, applied as per suggestion – Yash Shah Jan 18 at 7:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.