To preface this, I owned this mouse for over a year now and have used it with no problems on this same hardware with different Linux distros (Fedora, Arch, Manjaro). It was not until I installed Debian 9 that I started having issues.

Firstly, the only way I am able to get the mouse to pair is directly after a reboot, otherwise pairing fails altogether. Then, after pairing or turning the mouse on for the first time, the mouse will connect and the light turns solid for about three seconds then the light on the mouse begins slow blink as if nothing is connected to the mouse. At no point during this process does moving the mouse cause the cursor to move on the screen. Additionally, after connecting the mouse initially, running the info command in the bluetoothctl terminal prints the following output.

Device D3:08:24:D5:FE:3F
    Name: MX Master
    Alias: MX Master
    Appearance: 0x03c2
    Icon: input-mouse
    Paired: yes
    Trusted: yes
    Blocked: no
    Connected: yes
    LegacyPairing: no
    UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
    UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
    UUID: Device Information        (0000180a-0000-1000-8000-00805f9b34fb)
    UUID: Battery Service           (0000180f-0000-1000-8000-00805f9b34fb)
    UUID: Human Interface Device    (00001812-0000-1000-8000-00805f9b34fb)
    UUID: Vendor specific           (00010000-0000-1000-8000-011f2000046d)
    Modalias: usb:v046DpB017d0017

The mouse continues to show as Connected: yes even after the mouse disconnects or is powered off entirely. I have tried unpairing and pairing the mouse numerous times under different conditions. I've tried the advice from the following posts:

I am running BlueZ version 5.43-2+deb9u1 on Linux kernel 4.9.0-8-amd64 on a Thinkpad T480. What can I do to solve this?

2 Answers 2


I had the same behaviour you describe - it would connect but nothing happened.

I found that I was missing a certain kernel module, UHID. After enabling this, and re-connecting the mouse, it worked.



Starting with linux kernel v5.9, Bluetooth stack tries to use link-layer privacy on BLE connections.

This workaround works in my case with MX Master 3:

  • remove below lines from /var/lib/bluetooth/<adapter_mac>/<device_mac>/info

  • systemctl restart bluetooth

The devices will connect automatically after this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .