I'm using Debian testing and I'm having problem with installing Musescore 3. I'm trying to compile it, and I have tried following these guides:

General linux and BSD instructions

Ubuntu 14.10 and 16.04 instructions

It seems like the issue is that there's one package that I'm missing, because the guides asks me to install qtquick1-5-dev but that package is no longer available in Debian. I know that Musescore exists as a package, but it is to old. Also, I don't want to use the app image.

The error message begins like this. Tell me if you need more.

In file included from /home/me/src/MuseScore/mscore/musescore.cpp:116:
/home/me/src/MuseScore/mscore/startcenter.h:24:75: error: expected class-name before ‘{’ token
 class MyWebUrlRequestInterceptor : public QWebEngineUrlRequestInterceptor {
  • The header containing QWebEngineUrlRequestInterceptor class was not included before. The most likely reason is some incompatibility between your sources and the Qt version. – peterh - Reinstate Monica Jan 12 '19 at 8:20
  • I changed the question to better suit my ultimate goal, and since there are no answers that get's invalidated by this, it seemed appropriate. – klutt Jan 12 '19 at 17:30

seems like a compatiblity issue for now.

meanwhile, gnome-software gives flatpak support in debian testing. so you can try the flatpak : https://flathub.org/apps/details/org.musescore.MuseScore


appimage : https://musescore.org/en/download/musescore-x86_64.AppImage

  • Never heard about Flatpak before, but it worked like a charm. Thanks a lot. – klutt Jan 12 '19 at 17:05
  • Flatpaks & Appimages should be discouraged, because they can include malware & spyware. I really don't know why Musescore developpers are using this package format... – 71GA Apr 27 '19 at 19:12
  • 1
    Please don't spread FUD. Why would a file provided directly by the MuseScore team contain malware or spyware? Why would that be any different in case they distribute RPM or DEB files? – probono May 12 '19 at 9:21

I also had this problem on Lubuntu 18.04. I solved it by installing Qt from its own installer (downloadable from https://www.qt.io/download). I chose to install Qt5.8, but it also works for Qt5.12 (which occupies thrice as much space on disk). You need to

export CMAKE_PREFIX_PATH=/home/<username>/Qt/5.8/gcc_64
export PATH=/home/<username>/Qt/5.8/gcc_64/bin:$PATH

assuming that's where you installed Qt, if not change accordingly. Follow installation instructions otherwise. You might want to add those exports to your .bashrc if you expect to continue using Qt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.