0

I have an ancient CentOS 5.11 installation on an inhouse server. The server is due for upgrade in a few months but till then, I'm stuck with 5.11.

I intend to install google-cloud-print-connector but it isn't available in any repo so I'm trying to source compile it.

I have already installed all prerequisites, some from alternate repos, others source compiled however when trying to run

go get github.com/google/cloud-print-connector/...

I get the following error

# cd .; git clone https://github.com/google/cloud-print-connector /home/go/src/github.com/google/cloud-print-connector
Cloning into '/home/go/src/github.com/google/cloud-print-connector'...
fatal: unable to access 'https://github.com/google/cloud-print-connector/': error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
package github.com/google/cloud-print-connector/...: exit status 128

There are many questions here regarding this error however none of the suggested solutions work.

I have git version 2.9.5, openssl-1.0.2a, curl-7.42.1 which all support TLS v1.2.

I also tried git config --global --add http.sslVersion tlsv1.2 and other tls variants but to no avail.

Any ideas?

  • If the machine is telling you it is you are using non supported protocols, why not fixing the situation instead of not believing and trying to fix it? – Rui F Ribeiro Jan 11 at 8:49
  • Care to elaborate? The error says I need to use TLS 1.0 and I tried that along with other TLS as well. – user330934 Jan 11 at 9:06
  • 1407742E "tlsv1 alert protocol version" does not mean you "need to use TLS1.0"; it means the alert code for protocol version (70) was first defined in TLS1.0. github since about a year ago only supports TLS1.2 and apparently you're not sending it but I have no clue why. As a start try openssl s_client -connect github.com:443 -debug and see whether that succeeds (with 1.2) (note: many hosts nowadays require -servername on s_client for SNI but github currently doesn't) – dave_thompson_085 Jan 11 at 11:31
  • As far as I know, github only supports TLS1.2 and newer; RHEL 5 only supports TLS1.1 and older. So the git command that comes with CentOS5 won't talk to github any more. – Stephen Harris Jan 11 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy