I have OS CentOS Linux release 7.6.1810 (Core), Apache/2.4.6 (CentOS), Redmine v3.4.6. My site works nice with http, but I want add https support to it. But when I try use https it has endless loading in my browser and then error: This site can’t be reached took too long to respond. I checked my open ports with:

sudo netstat -tulnp

I can see here: enter image description here Also I checked it with:

sudo firewall-cmd --list-all

I can see here: enter image description here

My iptables.service not is inactive (dead). I thought that problem was in SELinux, I tried set setenforce to 0, but it did not improve the situation, so I returned setenforce to 1. I test my httpd config - no errors only: WARNING: PassengerRoot cannot occur within section Syntax OK

I set LogLevel debug in my httpd.conf. But I don't have any error in my logs, moreover as I see on logs with ssl everything is all right: enter image description here

Here is my .conf for my site:

<VirtualHost *:80>
    Redirect permanent / https://myservernamehere/
    ServerName myservernamehere

<VirtualHost *:443>
    ServerAdmin admin@myservernamehere
    ServerName myservernamehere

    DocumentRoot /home/redmine/redmine_ftp/public

    PassengerRoot /usr/local/lib/ruby/gems/2.2.0/gems/passenger-6.0.0
    PassengerRuby /usr/local/bin/ruby
    PassengerUser redmine

    <Directory /home/redmine/redmine_ftp/public>
      Allow from all
      Options -MultiViews
      Require all granted
    PassengerAppEnv production
    PassengerHighPerformance on

    SSLEngine on
    SSLCertificateFile /etc/letsencrypt/live/myservernamehere-0001/cert.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/myservernamehere-0001/privkey.pem
    SSLCertificateChainFile /etc/letsencrypt/live/myservernamehere-0001/chain.pem

    SSLProtocol             all -SSLv2 -SSLv3
    SSLHonorCipherOrder     on

    <IfModule headers_module>
        Header always edit Set-Cookie ^(.*)$ $1;HttpOnly;Secure
        Header always set Strict-Transport-Security "max-age=15768000; includeSubDomains"

So problem not in SELinux, ports are open, no errors in logs.

Updated It's not about Apache or Ningh or Redmine, even on a simple standard page, https does not work.

  • Can you try running openssl s_client -connect [your-domain-name]:443 and add the output here? – Haxiel Jan 10 at 7:45
  • @Haxiel I got socket: Bad file descriptor connect:errno=9 – Vladimir Goncharuk Jan 10 at 7:58
  • That looks like a connectivity problem rather than an SSL problem. You seem to be listening on IPv6, so hopefully you have already accounted for that. From a remote host, can you try nc -v hostname 443 or telnet hostname 443 and see if it connects? – Haxiel Jan 10 at 8:03
  • @Haxiel I got Connection timed out – Vladimir Goncharuk Jan 10 at 8:08
  • Can you confirm that you want to use IPv6 here, and that your network is configured to handle it? – Haxiel Jan 10 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.