2

I have a Ubuntu 18 VM and am trying to install an Oracle XE 12c database locally. I have downloaded the related .rpm file and try to install it as instructed via:

yum -y localinstall oracle-database-se-18c-1.0.1.x86_64

However, I'm getting the following dependency error:

yum -y localinstall oracle-database-xe-18c-1.0-1.x86_64.rpm 
Setting up Local Package Process
Examining oracle-database-xe-18c-1.0-1.x86_64.rpm: oracle-database-xe-18c-1.0-1.x86_64
Marking oracle-database-xe-18c-1.0-1.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package oracle-database-xe-18c.x86_64 0:1.0-1 will be installed
--> Processing Dependency: file for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: net-tools for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: oracle-database-preinstall-18c for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Finished Dependency Resolution
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: file
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: net-tools
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: oracle-database-preinstall-18c
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: /bin/sh
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I do have sh and file (apt-get install net-tools).

I got the same exact error in Debian 9 VM. What seems to be the problem.

  • 1
    Have you try to install it on Ubuntu way? askubuntu.com/a/739718/680869 – Romeo Ninov Jan 9 at 17:32
  • And there is a Debian tutorial for Oracle XE Databases - wiki.debian.org/DataBase/Oracle - You will get nowhere trying to install an RPM package inside Ubuntu or Debian... – user34720 Jan 9 at 17:37
  • @RomeoNinov Where do I get the actual zip? The Oracle site only provides .rpm. Besides, the instruction is geared toward 11 which is most likely different from 12c. – Malvon Jan 9 at 17:41
  • @nwildner Where do I get the actual zip? The Oracle site only provides .rpm. – Malvon Jan 9 at 17:41
  • install Oracle XE. – Romeo Ninov Jan 9 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.