I am running a Fedora Core 13 with dm-crypt + luks, all standard with fedora distos.

After upgrading libgcrypt.so, cryptsetup moans at boot up that it can not find the library where it expects it to be ( /lib ).

So I booted with a live cd, decrypted the root partition of that drive, and mounted my old hard drive, then I chroot'ed in there.

I ran cryptsetup and as expected it bombed out with the same error as when booting up... I fixed the symlinks, and tested cryptsetup. It worked.

When I rebooted the same error was there again... I thought that somehow my changes was not being saved. So I booted back into the live OS, mounted the hdd & chroot'ed again, and to my amazement I found my symlink where I left it and cryptsetup working.

Can someone tell me why this is happening? Why is cryptsetup still looking for the file in /lib and not finding it when its obviously there?!

P.S. I have also tried making duplicates of the libgcrypt library files in /lib as well as tried recompling cryptsetup from source, it all works 100% untill I reboot and then that error again!

I am thinkin' of just rebuilding that box, but I thought I'd ask you guys first? Anyone come across a similar issue?

  • Your symlink might have been removed by ldconfig. Your description is confusing, could you edit it with the exact file names involved at each step? – Gilles Dec 17 '10 at 21:05

Try rebuilding your initramfs files. It's possible that a static copy of libgcrypt has been incorporated into the initial ram disk (to decrypt early disks, for example), and it is still the version prior to the package upgrade.

  • all good just reverted back to my old kernel, need to rebuild that beast soon! – Count Dashula Jan 26 '11 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.