0

This question already has an answer here:

I am trying to run Secondlife in Linux Mint 19. However it's a 32-bit program and I'm running a 64-bit system. How do I install a 32-bit compatibility environment in Linux Mint 19?

marked as duplicate by Christopher, G-Man, Gilles linux Jan 8 at 17:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

try something like this:

dpkg --add-architecture i386

apt-get update

apt-get install multiarch-support

apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386

If your app require more libraries, install everyone with :i386 at the library name.

Ubuntu packages website can help you to found out, the packages providing files, that eventually are missing.

  • Thank you for the edit and the advice about multiarch-support not needed anymore. – Luciano Andress Martini Jan 8 at 16:52
  • thanks for the help. None of the code worked.I encoutnered an error when trying to run the first line (dpkg etc.) with dpkg: error: unable to create new file '/var/lib/dpkg/arch-new': Permission denied I tried running it with sudo and nothing happened. I will check the website – Leo Ohyama Jan 8 at 17:01
  • It will not return nothing, just run it , and try again to execute your application at end. Showing the errors for us. – Luciano Andress Martini Jan 8 at 17:08
  • It seems to be a connection error. Which doesn't make sense because my connection is robust (I'm on a University's network that allows secondlife This is the error: 2019-01-08T05:16:33Z WARNING: LLViewerMediaImpl::navigateInternal: Couldn't navigate to: viewer-login.agni.lindenlab.com/… as there is no media type for: text/html – Leo Ohyama Jan 8 at 17:16
  • 2019-01-08T05:18:51Z WARNING: stageAfterCompletion: HTTP request 0xf392d410 failed after 5 retries. Reason: Couldn't connect to server (Easy_7) 2019-01-08T05:18:51Z WARNING: onCompleted: -------------------------------------------------------------------------- Error[Easy_7] cannot access url 'sim10730.agni.lindenlab.com:12043/cap/…' because Couldn't connect to server ------------------------------------------------------------ 2019-01-08T05:18:51Z WARNING: requestBaseCapabilitiesCoro: Received capabilities for region that no longer exists! – Leo Ohyama Jan 8 at 17:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.