0

I run quotacheck on a filesystem to enable user quota only so now the following file is present:

root@Cassiopeia:~# ls -l /mnt/imagemount/aquota.user 
-rw------- 1 root root 7168 Ιαν   8 15:21 /mnt/imagemount/aquota.user

(I have mounted a loopback device for the particular process)

However, when trying to enable quota:

root@Cassiopeia:~# quotaon -u /mnt/imagemount/
quotaon: using /mnt/imagemount/aquota.user on /dev/loop6 [/mnt/imagemount]: Device or resource busy

Why is it displaying the above message?

Do I need to make sure no process is accessing a particular filesystem before enabling quota? is there such a requirement?

  • what options did you mount the filesystem with? one I run quota on sets usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 for example – thrig Jan 8 '19 at 18:38
0

Ensure that the rights of aquota.user are 600 and try to type remount /mnt/imagemount before trying to type quotaon; if you do not remount after adding aquota.user, the system will not acknowledge the change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.