7

What I tried:

  • Tried using Nouveau
  • Tried installing NVIDIA drivers using Zypper
  • Installed NVIDIA proprietary drivers (and uninstalled Nouveau)

I was really hoping that the proprietary drivers would fix this, but it didn't. I got the drivers from https://developer.nvidia.com/vulkan-driver.

This is the error I keep getting:

Unreal Engine Vulkan device not available

5

A way I found in order to avoid this issue and work with the Unreal Editor without messing around with graphic drivers (I am on open source drivers shipped with Linux Mint) is to launch the editor with the opengl4 flag. In this way the Vulkan requirement is skipped and the editor can start properly. Using the terminal reach the linux binaries folder ~/UnrealEngine/Engine/Binaries/Linux and then use this code in order to launch the editor under Opengl4 ./UE4Editor -opengl4

5
  • Is it necessary to be in the directory  to run this command? – Scott Apr 28 '19 at 15:40
  • To run the second one yes, you need to be in the binaries directory because the code is just looking for the UE4Editor executable in order to launch it. There could be some more cleaver way to do it, but I am new to Linux and I am learning step by step how to deal with it and use needed software on it :) – Nazzareno May 4 '19 at 7:02
  • The normal thing to do would be to type ~/UnrealEngine/Engine/Binaries/Linux/UE4Editor -opengl4 from wherever you are. – Scott May 4 '19 at 7:36
  • 1
    Tried opengl14 flag but another popup shows up: Trying to force OpenGL RHI but the project does not have it in TargetedRHIs list. and close UE4Editor... – Richard Dally Apr 20 '20 at 11:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.